Kuka Krc4 Deployment Error : Culture is not supported

  • Hello guys,


    i have one error with a KUKA KRC4 robot, by mistake i have uploaded a symbol table to workvisual with 'gn' as target language as you see in the picture :


    robot-forum.com/attachment/28196/


    then i have deployed the program to the robot, and i go the following error :

    Unknown error on controller <WINDOWS-LBL6QBP (172.31.1.147)>: Unexpected Error: This fault is replacing an exception of type System.ArgumentException with message Culture name 'gn' is not supported

    and since then, i am not able to make any deployment, i get the same error all the time (even the initial project), does somebody have any idea what can be the solution ? Thank you.

  • AD
  • you screenshot is not showing up


    i guess you succeeded in transferring project but when KRC tried to activate it it fails. reboot simply brings you back to same point.


    the simplest solution is to restore HDD with good backup image. if you did not make one before, make it right now and then try manual recovery.

    i would try manually replacing that BadProject just deployed (C:\KRC\USER\ProjectRoot\BadProject\BadProject.wvs) with a known good project (whatever was previous working project or BaseProject) but make sure to change the name to that of 'BadProject.wvs'. reboot and cross fingers..

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hello guys,


    the project management was damaged, i solved the problem this way :

    1. In the main menu, select Start-up > Service > Minimize HMI.
    2. Click on the Stop KRC icon in the task bar.
    3. Delete all the folders contained in the directory C:\KRC\USER\ProjectRoot\.
    4. Delete the initial project in the directory D:\InitialProject\.
    5. Execute the file InitialProjectSetup.exe in the directory C:\KRC\UTIL\InitialProjectSetup\.
    6. Execute the file StartKRC.exe in the directory C:\KRC\.


    this way controller go back to the initial project (Factor settings). and error was removed.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now