PolyScope and UR version unclear

  • Hello everybody,


    first of all: i´m pretty new to this whole topic. I´m a workingstudent and usually do economical engineering. I got basic Java knowledge and an overall good computer experience. It is my first time on a robot, the UR5 in particular. So, please be easy on me. I´ve been reading the user manual, forum posts and i did the UR online Academy, because my boss wanted me to get into this and present him what the robot is capable of later on. I´ve been figuring out how to programm it, mostly trial & error. That´s when i started facing a lot of problems.
    The Robot itself is passed through a couple company intern people, leaving me without information about firmware, usage, whatsoever.


    Firmware atm: 1.8.14035


    My first question is, why the PolyScope GUI does not have the safety functions described in the user manual. For example: i´d like to configure safety planes.

    Here is a glimpse, of what my interface looks like:



    I´d be very thankful for any Information. Let it be tutorials, books, programming languages or how to get to the safety features.


    I know this is kinda unstructured, but im looking forward for your help!

    Paul

  • Place your Ad here!
  • Welcome to robotics!


    If you take a look at the manual for 1.8 it looks exactly like your screenshot. You must be looking at a newer version of the user manual. Since you are running 1.8 you must have a CB2 controller, which I doubt supports those Safety features. I don't know if updating will help anything, but you can take a look at the Legacy Download Center for instructions on updating older versions of the software.


    I hope that helps!

  • That indeeed, does help!


    Though i still do not know how to upgrade the Software. Do i have to plug it in via USB and boot the Robot out of the USB Compartment?

  • Instructions for upgrading can be found in the manual, section 5.4 Setup Screen -> Update. Basically, with the file on your USB stick, just click SETUP Robot > UPDATE Robot > Search... and select the file you downloaded from the Legacy Download Center, which should be 1.8.25319 in your case.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners