Roboguide virtual robot startup error

  • I've spent much of this week fighting with my Roboguide install. I was trying to create a cell from a file backup and kept getting a Virtual Robot Status error -- "Connection with the virtual robot failed. You may need to reboot the PC to avoid this issue". When I close the popup, Roboguide shows another window "the virtual robot has experienced problems during startup. ROBOGUIDE is unable to proceed and will terminate." I have rebooted plenty with no luck.

    There's a long application error log that I've attached. At first, I could open my other cells in Roboguide but when I went to create the new one I needed from a file backup I received this error. My other coworkers were all able to open the file without issue, but I kept receiving the error. I completely uninstalled and reinstalled Roboguide and now I get this error whenever I try to open any of my other cells too. One of my coworkers said he had a similar issue a few months ago and the only way he got it working again was a complete windows reinstall. My boss suggested trying to roll back to a system restore point, but even that would make me have to waste a bunch of time reinstalling other software I use. Any ideas short of that? I'm at a loss.

  • Can't believe it was that simple but that worked. Thanks for making me check the basics. I had been just launching ROBOGUIDE from the desktop icon with no issues before this. Right click -- run as admin and I got the cell to load.

  • This also fixed it for me.
    A few months back I switched to integrated graphics because my NVIDIA driver update resulted in my projects no longer loading properly. I've had it working for years but it randomly broke.

    I feel silly for not thinking of trying this but I guess it's because it had been working previously.


Advertising from our partners