KRC4 Connection Issue - "Error During Cyclic Communication"

  • KSS: KRC4 8.5.0

    Robot: KUKA iiwa 7 R800

    OS: Windows 10
    Sunrise Workbench: 1.16.2.16

    WorkVisual: 5.0.10/Build0927 (with Sunrise.kop: 1.3.15.0)


    The error that is being displayed on the teach pendant is “Error during Cyclic Communication”. This error requests you turn the key switch to the operator mode page. The error still remains after turning the key. After rebooting the controller, the teach pendant still showed this error. See images 1-3 attached.

    I tried to reload a program and that still didn’t fix the error, I found that the battery had not been plugged in to the controller following shipping, which when plugged in it still did not fix the error. After that it was suggested to use a recovery stick and load a fresh image to the controller.

    This seemed like it fixed the issue as the robot was able to be jogged and applications selected and manually run through. But unfortunately today the same error appeared again. However, now it’s not whenever the pendant is booted up, but only when you initially turn the key switch. In T1 mode when the robot boots up it appears to operate as normal, but turning the key switch and attempting to put the robot in auto mode, the error shows up again and cannot be removed until the controller is power cycled.

    The 4th image is another warning that comes up but I am still able to jog the robot despite them. These may or may not be related.

    Also, after using the recovery stick all the parameters for the KUKA systems gripper that had been installed were cleared. I have been attempting to reconfigure them and have had other programming issues on the computer, but at this stage I don’t think that is related.

  • So with the Sunrise work bench what did you mean by "reload a program"? Synchronize the current project or install a project?

    If the system has booted and run with the current project and you are then getting a cyclic connection error' connect a computer monitor to the DVI port and reboot the controller to see the status of any potential errors on the PC. If you have used the recovery image to reload the Windows basis image, you need to install and the synchronize the current project to get the sunrise OS on the controller. default IP 172.31.1.147


    From the one screen shot (4.png) where the Sunrise OS was loaded' the "No safe connection to SION CIB SR" points to the I/O mapping between the WorkVisual project and Sunrise Workbench. Might also be something related to the safety configuration in the Sunrise Workbench.


    Regards JT

  • When I said "reload a program" I meant I installed and synchronized a project. I even started a new project from scratch.

    Last week I replaced the ethernet cable between the KSB port and the X41 port and the error was cleared. The controller was working fine even after a few reboots and then I come back to site today and I turn the controller on and the same error comes back. I am going to check if I have any spare cables to test with, but do you think this points to the cable going again? Because like I said I fixed the error for a whole day and then come back on the weekend without anyone touching or running the controller and then the error is back again.

  • when i connect a monitor to the DVI port, and open up device manager. I do get one device in the "Other Devices" branch. When I open that up it comes up with a "PCI Simple Communication Controller" with a yellow exclamation mark. I open properties up for that device and it says "The drivers for this device are not installed." Could this be the issue?

  • It seems that you probably have configured a faulty MediaFlange type for your robot.

    I/O Group should have MediaFlangeIOGroup unless you're using a MediaFlange without any I/O (and there are only 2 out of 10 variants).

    In the same sense, your X650-651 cable connection could be not stable.

    Or for the last, the Gripper connection could be the cause as well.

    -> According to your error "SION CIB SR", some node of your EtherCAT connection is malfunctioning.


    In the figure 2, try press a long bar where "HMI OK | 0 | (empty)" is displayed.

    You will see it something like "HMI disconnected" and then "HMI connecting" to "HMI connected" when you press it again.

    Then try turn the key switch back. You may have your HMI back.


    If you were not the one who somehow messed with the settings up, you should ask for a support to where you got the robot from.

Advertising from our partners