Cognex camera installed on a Universal Robot UR10 communication problem

  • Hello Forum,

    I have a Universal Robot UR10 and I am trying to connect a Cognex 7905 camera to the robot. I have the camera mounted next to the end effector focused at the gripper TCP. I am trying to establish the connection using TCP/IP with a socket port. I have set up the camera in the Cognex Insight Explorer. I am not able to get the camera and the robot communicating. I have the correct IP addresses and I have tried different socket ports. I have tried 30001, 30002, 30003 and a bunch of others.

    I have tried checking to see if the ports were sending any data using Socket Test Tool and it could not establish a connection to the sockets.

    I have the URCap installed. I am not using a PC or PLC in the system. I am trying to connect the camera directly to the UR10.

    I have reached out to Cognex, UR, robot integrators and searched online. I find information that is helpful but nothing that has solved my connection problem.

    Any help is GREATLY appreciated.

    Thank you and stay safe.

  • Hello!

    I remember attempting TCP/IP a couple months back and I remember it working. I forget the specifics of what I was doing in the program as it has been some time, but I figured some screenshots of my program might help you nonetheless.

    I ended up phasing out the TCP/IP because I am using a PLC with Ethernet/IP protocol now. EIP covers my bases, so I did not develop TCP/IP any further than this.

    I have a UR5e so I am not sure if this will help you on your UR10.

    - Vin

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now