SmartHMI not starting on boot after recovery

  • After performing a recovery of my robot (KRC4 v8.3.14), The SmartHMI fails to load and instead opens up to the Windows 7 desktop. From there I have to select this executable to get the SmartHMI running: C:\\KRC\StartKRC.exe


    I had done a stupid thing and changed IP address from windows settings side of things. I know, rookie mistake. I don't know if the recovery image I am using is a good match. We only have a couple recovery sticks and there's no telling which stick goes to which robot or KSS version. We probably don't even have a proper recovery stick and image for this robot to be honest.


    That said, after picking one, and doing the recovery, the robot seems fine, except for the issue I stated at the top.


    Any ideas why the SmartHMI isn't booting automatically and what I can do to fix it?

  • AD
  • this is actually a hidden directory


    You also can co it the hard way


    Move the short cut with mouse to programs, start up. Here you will see probably empty. Move down until empty is underlined then release mouse button and the short cut should be there

  • Protip: as soon as the KRC is in a good booting condition, use the KSR stick and make a full hard-drive image of it. Then store the image files offline somewhere safe, in a directory labelled with the robot's ID and the date/time.


    I make it a standard practice to do this for every KRC that comes into my hands, before I do anything to it. It's the only way to have a guaranteed fallback. And generally an "as shipped" image after customer buy-off but before the robot leaves my facility. And ideally, I do it again after final on-site buyoff, and give the customer a copy as well as keeping one for myself.


    The KSR recovery images are bulky, but storage is cheap these days.

  • Protip2: as soon as controller is powered up make a HDD image... even before you make any changes. then make another image when everything works the way you want.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now