DeviceNet Fieldbus Error (Unstable comunication) KRC 2

  • Hello,

    I have a KUKA KRC2 controller using DeviceNet Protocol to speak to a Siemens S7-1200 PLC. In order to stablish the comunication, I'm using an Anybus-X Gateway DeviceNet Adapter-ProfiNet IO Device.

    Once the comunicaction is stablished, the robot sends at most 512 bytes properly to the PLC (devnet.ini and IOSYS.ini already configured and no DN2DRV errors at all).

    But when it comes to programming the Robot, it suddenly stops moving either in T1/T2 or in Auto. Since I've seen in the forum, this usually happends when the wiring is not wisely done so I started checking the hardware.

    Apparently, neither the MFC nor the Gateway shows any error, but when it comes to voltage, CanH-CanL is around 1/1.5 V.

    Both sides of the cable has a 120 ohm terminator resistor, and CanH canL resistance without plugging any device is around 60 ohm which seems fine.

    The power supply used is the KUKA KRC2 one but an external 24V has been also tried in case the KUKA 27V where messing around with the gateway.

    Mesh has been also tried both connected and not connected to 0V since it was recomended in some posts here.

    Thank you in advance!

  • AD
  • Industrial bus networks like this operate on 5V...

    so square wave is normally getting close to 0V and 5V with average about middle of that range... which is 2.5V. This is a differential pair thus allowing tolerance to wide offsets so it does not need to be in dead center though every system i checked was pretty close to 2.5V or 2.8V on either CanH or CanL relative to GND.

    but more importantly both readings are nearly the same - difference as i recall was always 0.1V or less while yours is good 0.5V. this looks suspicious and i would say this should be investigated closer. most likely something is not right with the wiring or one of the nodes, perhaps terminating resistors are connected incorrectly (to 0VDC instead of across differential pair).

    if you have real oscilloscope (not Trace tool that is part of KSS) check the wave forms for any distortions or noise. make sure that cable is really shielded (stripping shield more than 2-3cm for cable in this application is not "shielded" any more), and if grounded in one place only. also make sure your robot and controller are grounded... using KUKA recommendations (dedicated 16mm^2 conductor, from robot to controller and then from controller to building GND). having only GND wire in a AC power drop to controller does not count.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now