Setting SNN in a 30ib Mate Plus controller

  • I am trying to setup Ethernet/IP communication with CIP safety between a Contrologix PLC and a 30iB.

    I am currently stuck on the SNN.

    In the Fanuc AOP under connection it says "(Code16#080d) Safety number not set, device out-of-box"

    I followed a guide provided by fanuc and inserted the HEX of the total signature number, and entered 1/1/2009, 1 am in the time after changing the config signature date to fixed.

    clicked OK, downloaded, but nothing changed. The SNN stays at FFFF-FFFF-FFFF-FFFF

    What am I missing?

  • Hope yall don't mind me resurrecting this, but I'm having the exact same problem. My issue is that I've tried all of the above, but I'm having the following issues:

    - Cannot inhibit the module(box is grayed out) and I'm getting the code 16#080d(Safety Network number not set, device out of box)

    - SNN in the robot was initially set to fixed, tried setting it to "Auto(or whatever it is)", applying DCS, resetting and then resetting ownership but the Config still states Remote(SNN:FFFF-FFFF-FFFF, Address:)

    - I was able to get the SNN in the robot to match the SNN in the Fanuc AOP in the GuardLogix processor once, but it still balked at the ownership reset. When the robot reset, it went back to FFFF-FFFF-FFFF and now won't change no matter what I do.

    - I also cannot change the SNN in the Fanuc AOP(not sure if I should be allowed to do that).

    - The one thing I have not tried is doing this with the PLC in program mode. Is this a requirement?

    Any ideas?

  • Update: Program mode worked, but something else to consider. When I reset ownership, the PLC then prompted me that the config signature didn't match. Someone else made other DCS changes that started all of this, and I had to annunciate a new signature and then copy that code back into the module in the logix processor to be able to get comms back.


  • Digging up a post I dug up last month. Got another robot with a "Safety Network Number Not Set: Device out of box." Followed every step from these previous posts, but I cannot get the Safety Network Number on the robot to reset what I generated on the GuardLogix. Slightly different system:

    1769-L30ERMS Processor

    R30iB Plus running a R2000iC 165F robot.

    Steps I took:

    1) PLC in program mode

    2) Robot ethernet module inhibited on PLC

    3) Set Ethernet IP connection with PLC to FALSE on ROBOT

    4) Generated new configuration signature on ROBOT

    5) Input new configuration signature in Safety tab on PLC

    6) Generated new SNN on PLC

    7) Reset Ownership

    This did not work. I tried changing DCS CIP Safety signature configuration to Fixed and Actual, no change. Tried all combinations of EIP Scanner True/False and CIP Safety ENABLE/BYPASS.

    Robot SNN Stays at FFFF_FFFF_FFFF_FFFF no matter what I do. Fanuc forum wasn't much help, just sent me over the DCS configuration PDF.

    Any thoughts?

Advertising from our partners