Permission System Glitch

  • This is a very odd problem that has only occurred on one of our robots to my knowledge, but has now occurred two different times.


    The first incident, occurred many months ago, date unknown, but probably less than 3 years.

    The robot in question has Passwords set up with 7 different users, and custom XML definitions. The same definitions are used on a few other robots.

    One day, one of our technicians approached the robot, but was unable to log in, because the screen would not appear. He needed to log in so that he could touch up a weld position, and was unable to do so. The next morning, it was escalated to me, i walked up to the pendant, and everything worked fine. No one has mentioned this error again until yesterday.


    The second incident occurred on the same robot as before. First indication of an issue came when one of the engineers was unable to change one parameter of a DCS setting. To be specific, they were trying to add a maximum permissible speed for a Cartesian Position Check, which presented no problem on identically set up robots. When they made the change, it immediately reverted back, and they called me. I verified that the issue was repeatable, occurred on Joint Speed Check as well. I tried to log in at the Install level, but the password screen did not exist. I toggled to Full Menu and the Setup tree showed Password, but when clicked it would not navigate to the screen. We cycled power, and the problem persisted.


    We tried with Quick and Full Menus, and we tried HMI Menus, but nothing worked. We were able to log in from the Menu+i screen using the function key for Install, but still could not get to the Password screen to disable.


    We cycled power and entered a controlled start, and were finally able to enter the password setup screen and disable passwords.


    After cold starting from there, we were still unable to make the DCS change we had originally wanted to. Since both items have to do with permissions, and both are occurring on only one robot, i am suspicious that the two are connected.


    My primary question is, has anyone else encountered this, and if so, was there a reliable fix? Just waiting for it to work again isn't going to work out.

  • AD

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now