copy file to FTP site via RAPID IRC5

  • Hi,

    I am facing an issue using FTP with my IRC5 (robotware 5.15) system.

    I want to copy files from the robotcontroller to the external FTP site (PC:/). The FTP server is UP (event msg 10076).

    When using the flexpendant --> flexpendant explorer I am able to copy the file from the home directory and past it on the PC:/. Creating a backup from the flexpendant to PC:/ is also without a problem.

    The problem occurs when I am trying to copy the file to the PC:/ with a rapid command:


    VAR string filename_PC:="PC:/bar1.txt";

    VAR string filename_robot:="HOME:/PRODUCT1/bar100.txt";


    !copy file

    CopyFile filename_PC,filename_robot;



    The error generated is "File Access Error" 40548.

    In this case I tried to copy a file from PC: to HOME:. The other way around gives the same error.

    So: there are no problems with reading/writing the ftp site from the flexpendant explorer but when using RAPID code it will not work.

    Does anyone has a clue how to solve this??

    KR Ruud

  • Hello Team,

    Can someone help me..

    In my upcoming project Customer has one Line PC and in that 10 robots are connected IP of line PC is 192.168.16.XX.

    Customer requirement is they will press backup and the backup will save in that Line PC in a particular folder.

    In robot we "FTP/NFS client option" and "PC Interface option" too.

    Please help me I'm new to Network programming.


  • Which version of RW is it?

    In any case you will need to consult the parameter (I/O System) for the system input Backup, and (Communication) for Application Protocol.

    See the documentation in RobotStudio under the File tab in the Help section.

  • Thanks for the prompt reply.

    Yes I told customer but he is asking for he will press the backup and the back will save in Remote PC

  • My RW is 6.12

    I know the coding for system parameter.

    But customer want it through FTP to a remote PC.

    Can i try on my laptop first because i downloaded Filezilla client in my laptop.

    Can anyone help.

  • From another board that was posted on:

    FileZilla Server is running on the device named

    ToolPC: with a static IP of

    One HUGE tip, change the default welcome message to


    Also the most current FileZilla server 1.1XX software has not been made to work for ABB controls with RW 5.15. It is suggested to download and use


    or later, or be willing to try and figure out with little FileZilla configuration information available how to get 1.1X to work.

    Reworking of the SIO parameters will be needed for RW6.


    -Name "COM1" -Connector "COM1"

    -Name "LAN1" -Connector "LAN"

    -Name "SER1" -Connector "SERVICE"

    -Name "TCPIP1" -Type "TCP/IP" -PhyChannel "LAN1"

    -Name "StoragePlace" -Type "FTP" -Trp "TCPIP1"\
    -ServerAddress "" -LocalPath "ToolPC:" -Username "IRC5"\
    -Password "XyZ" -MaxFileSize 150

Advertising from our partners