Fanuc DeviceNet DNET-070 device err

  • Hi guys,

    I'm trying to set up a Fanuc S430i to talk on a devicenet network to a compactlogix PLC via a 1769-SDN module. The network is up and has no errors on the PLC side, but when i try to set the Fanuc daughter-board's slave device (Rack 81 - Slot 1) to ONLINE, it immediately errors out. I get 2 faults, a DNET-070 and a DNET-068. The mac id of the 1769-sdn on the plc rack is 1, the mac id of the daughterboard is 2. these are the only devices on the network. I created the device because there was no predefined device for the 1769-sdn. i set all the parameters to match the RSNetworx 1769-sdn settings i.e. - the baud rate, vendor id, product type, and the IO comm data ( Polling ) The only thing im not quite sure on is how many "digital inputs" and outputs to set under the polling heading in the device setup... Im using a full assignment of UOPs - (18 and 20 respectively) , 32 DI's and DO's, and 16 GI's and GO's. Surely i don't count all of these as digital inputs and outputs with respect to the device setup screen, that makes no sense - as the GI's and GO's are integers... or do i count each and every bit that i want to pass through the comm..? I have allotted 80 bytes in and out on the PLC side to allocate and map IO, that covers all of my UOPS, digital IO, and my group IO... that is 640 bits of each. Since both sides match im not sure why im having this problem... any help would be appreciated...

    Thanks fellas

  • AD
  • I should add to this that i keep getting PRIO faults for bad IO assignments for rack 81, on slots that aren't even assigned to anything, such as slot 4 and 5... not sure if thats related or it's a symptom of the already described problem...

  • Thanks for Replying. There are only 2 devices on the network, the 1769-SDN and the robot's daughterboard - an SST 5136 DNP. I will try increasing the Baud rate, right now it's at 125kb

  • Changing the baud rate didn't help, I'm still getting the DNET-070 Connection allocation Error and when i try to reset i get a DNET-068 Device timeout.

  • I think the problem lies in the amount of Digital inputs and Digital outputs i have set in the Device definition. Under "Polled I/O:" I have 32 for each because i'm using 32 DI's and 32 DO's going over the devicenet network. I have tried adding the amount of UI's and UO's , but it didn't help. The edoc for this -

    (FANUC Robotics SYSTEM R-J3 Controller DeviceNet Setup and Operations Manual Versions 5.22 and 5.30 MARO3DENT05001E REV B ) describes this as " The number of digital input points supported by the selected I/O mode. " Does this mean the amount i put in here is the MAXIMUM amount of I/O supported by the 80 bytes i allocated for the connection? or just the digital I/O i intend to use?

  • Just a heads-up. I fixed this problem. I found there were system variables that someone had been messing with and had no idea. I did an INIT Start on the controller and reloaded my software options, and it solved all of my problems... of course i had to re-map all of my IO, but it took care of the issues...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now