Advertising

KRC2 booting issues

  • Softkeybar is Software that contains icons and actions for four programmable keys on the left side of the screen. Usually assigned to gripper or various tech packages.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • AD
  • sjx, MOM, panic mode thanks!


    I did start up controller and after Cross3 stuck again I used Ctrl+ALT+Delete to see what's wrong and I saw Explorer [Not responding]. So selected End Task for Explorer, than Ctrl+ALT+Delete and this time it showed Guardtray [Not responding], so I ended that, too. Next one was Guard9x [Not responding] -> End Task. Then KUKA started loading!!!


    sjx, read the threads you found, many thanks! I looked in to C:\KRC\BIN, there was no .freeze file (maybe I received robot with that file deleted). I forced cold Starup. Interestingly, the screen when on to stay long after I switched the cabinet off (this did not happen before)!! Now I remember, that some long time ago it used to be that after power off screen stayed on for some seconds. Not recently. Screen acts as if controller 2 batteries were old but they are not old, changed recently. When I started the cabinet on I got the same problem with Cross3 freezing :) Cold start did not help.


    I did all the same End Tasks for Explorer, Guardtray and Guard9x and KUKA loaded again. This time there were no usual messages ("Reboot after powerfail" or "Ackn. under voltage PM1")! Am I normally shutting the controller down incorrectly (by power off knob on controller?) Shall I always use Cold Startup to get it boot without powerfail messages? :) For what its worth, I tried Shutdown option in Windows, it got me to windows restarting and into dark screen later...


    So I did warm power on again. This time only Guardtray End Task (Explorer, Guard9x were not indicated as problem) an KUKA started loading and never finished (just showing clock item)...obviously I should have ended Explorer and Guard9x....


    Restart again, End Tasked all 3 apps, checked C:\KRC\BIN. No .freeze. There are Cross3, KukaBof, KukaDB, OleTest, vxworks.debug, and vxWorks.st files there. So I went to to Monitor -> Diagnosis -> Log book -> Display. Last logs seem for the day when things went wrong. One strange message I see "Safety circuit has detected an error. Use ESC-Diagnose for further information".


    Will try to unplug X21 when pendant not lighting next time...

    Also, apparently I have lost mastering, but that's not an issue, I have done it before...

    I assume now I have the chance to use File -> Restore -> ??? after I have cloned SSD card to at least be able to get back where I am now if it does not work :) as I have no Windows CD.


    What do you think about Guardtray, Guard9x? :)

    Sorry for long post, just wanted to document it properly

    Thanks for all your guidance!

  • Hi

    I'm glad you were able to start the computer.

    First of all stop any trying to start system before hdd clone. The most important is to save current status of HDD. In this way you can start Windows from him.

    As far as I know you do not have installation discs. I mean Windows OS and KSS instalation disks. Therefore You need to clone HDD. You can clone HDD on every IDE HDD if you have one, even old HDD but whitout sectors errors. For future purposes you can buy new SSD.


    Start system whith the cloned HDD. If KSS does not start, reinstall KSS from "D" partition over current instalation on partition "C:" Du not delete current installation.


    To start reinstallation proccess while Windos starts, press SHIFT KEY to stop starting of KSS.

    Start windows explorer, go to d: and find KSS instalation folder.

    Reinstall KSS

    I hope the system starts without errors, but if problems still occur, we will look for a solution. As I have already shared, I have no experience with KUKA ROBOTS, I am currently studying, and if I am wrong, I hope the experienced guys from the forum will share better solutions.


    Even you current HDD is not damaged, making a new one (as spare HDD) is good for the future.

  • pipo, Thanks, yes I agree. The only nuance is my current KRC2 system does not have any HDD! It only has InnoDisk InnoLite EDC 40P-V 8 GB (DE0H-08GD51AC1DN) Embedded Disk Card attached to motherboard. I am currently in the process of getting exact same old EDC card model so when I do my first ever clone and physically change cards on motherboard I have less potential issues. Not sure if this assumption is correct.

    • Helpful

    Hi

    the InnoDisk - The computer does not know that this is no ordinary hard drive. You can clone it the same way you clone a regular hard drive.

    Do you have another computer with two IDE ports and a USB port.

    If you don't have one, you can also clone on the KUKA computer.

    Tell me what you have to tell You how to do the cloning

  • agreed, as far as KPC is concerned, that is the HDD. inner working of device is not important, it interfaces to a KPC as a standard PATA HDD and it will be used as one. so backup procedure is the same too.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Thanks, this is helpful to know.

    Oldest PC I have is with two SATA HDD slots. Just ordered two SATA to IDE converters. Will let you know :)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now