Irb 1600 calibration issue

  • Hello I’m new to the forum but have found lots of information in the past from this site.

    I have a problem with our robot which has 6 axis. When I calibrate axis 1 2 3 the value changes to 0 and when moved back to calibration point it remains 0 however when I repeat the procedure with axis 4 5 6 the value sets to 0 but when moved back to calibration point it is always showing -2.6 have tried fine calibration and checked offsets are correct and sent data to smb and cabinet and no matter what I do it always returns to -2.6 and the joint is out of position if anyone has any ideas I would be very grateful kind regards andy

  • AD
  • Welcome!


    Since the term calibration is used by some of my customers when they are actually updating the rev. counters, I'm going to guess what your issue may be if nothing has physically changed on the robot.


    First, make sure the axis 6 fine calibration number matches the sticker on the robot. You can view this number in the parameters. If it does not match and nothing has physically changed on the robot, then manually entering the number from the sticker into the axis 6 fine calibration parameters should fix it.


    Note: The fine calibration numbers are listed in radians. If axis 6 fine calibration number is <0.3 or >6.0, you must be extra careful to make sure the axis is precisely aligned before updating the rev. counter. Axis 6 on the IRB1600 can be difficult line up.

  • Thank you so much for you help. I have checked the numbers on the sticker and they all match. I have tried so many things and no matter what I do joint 4 5 6 are not at 0 when using moveabsj joint 1 2 3 always report 0 but 4=-0.6 5=0.1 and joint 6 is always -2.6

  • It’s a very strange problem because no matter where I update rev counters for Joints 123 they always report back 0 when moveabsj is executed even if not in correct position but not matter what I do 456 never report 0 when moveabsj is used

  • We have 8 of these robots and I’ve just updated another robot rev counters with same tpu and all report back 0 as it should it’s just this one robot that Seems to have -2.6 set somewhere as 0 as whenever I run moveabsj it always defaults to -2.6 and not 0

  • Thank you so much lemster68 upon viewing jposcal it was set to -2.6 for joint 6 set this to 0 and it’s now perfect can’t thank you enough I owe you a beer or 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now