Kuka OfficeLite and EthernetKRL example server program not working (.net framework missing)

  • Hi Forum,

    at the Moment i am trying to make the EthernetKRL work in Kuka OfficeLite. I use KSS 8.6.1 and EthernetKRL V3.1.0

    I already read a lot of posts here but i couldnt find a post with my problem.

    I know that i Need Kuka router for communication with outside OL PC. I am working on getting that from Kuka. But in the meantime i am wanted to use the EthernetKRL example EthernetKRL_Server.exe in Office Lite but when i start it i get the error: "An app on your PC Needs the following Windows feature: .NET Framework 3.5(includes .NET 2.0 and 3.0)"

    i tried to download and install it, but that doenst work and the program wont start.

    Anyone else had that problem before? and i dont have the .net Framework on my pc is it possible to communicate at all with outside PC?

  • Place your Ad here!
  • KSS 8.x no longer needs KUKA Router -- that was strictly a KSS 5.x requirement.

    I haven't used OfficeLite since KSS 5.6, but I thought that OL 8.x ran inside a virtual machine of it's own (provided by KUKA)? The VM should have whatever .NET frameworks are required.

  • that seems odd... what is the exact version of the server?

    i am using OL8.5 which runs on Win7 32-bit

    and the host machine is running Win10 64-bit.

    both have installed framework 4.0 and example server that was includes with EtherentKRL 3.0.3 runs just fine in both environments.

    btw servers are easy to make, there is tons of tutorials online, even on youtube.

    as for router in OL8.x, i am using it right now. OL does not have KLI exposed so router is used to create tunnel from vxWorks > Win(embedded) > Win(host).

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Thanks for all the answers.

    OfficeLite runs on a Win 10 virtual machine and the provides EthernetKRL server doenst work there because of the missing .net framework. but this doenst bother me anymore.

    I managed to get the Kuka router software and followed the instructions in another thread and created a route from localhost to the ip of my vmnet8 adapter ( on my host pc with the desired port number. i started the server on my host machine and the example xmlcallback.src on the kr c4 with the internal ip of the virtual machine ( configured in the xml and this worked. i got a connection to the server on the host pc.

    But now i am trying to configure the server on the kr c4 and the client on my host pc and i doenst really work. i used the example XmlServer.src and xml files (there is a mistake in them btw. in the xml <ALIVE Set_Flag="1"/> is set AFTER ip and port is configured but if you look in the documentation it has to be set BEFORE ip and port)

    Anyway i tried to start the server and when i used the ip which is set in the network configuration tab on the kr c4 the server program has no errors, starts the server and wait for flag[1] to be set to true which should happen when the connection is established.

    I then wrote a small c# script (which works with other servers) and used the port i configured in the XmlServer.xml file and the ip of the virtual machine (not the ip configured in the network configuration of the controller) and the program seems to establish a connection. in the router program i see that the route to the ip of the host pc is used and the state is "connecting" with a yellow light. but it never connects and the flag[1] never is set to true.

    anyone has an idea where my mistake is?

  • i think i just solved it.

    i configured a new route in router: and with my port. and in the server.xml i used the ip in network configuration of the robot and i connected to it from my host pc in c# with the ip of the virutal machine and then i had a connected route in router and flag[1] was set to true.

  • Hallo julian122,

    I am very confused about your description.

    OL does not have an KLI - this is why you have to use the router.

    The kr c4 has the KLI - router is not needed.

    How is the KLI configuration? I think the problem is right there.



  • i understand waht you mean. my word choice was bad.

    i always talked about OfficeLite. never about a real robot

    and with kr c4 i meant configuration in the hmi.

  • To install .NET Framework 3.5 on OL's VM you will need to do the following (worked for me):

    You need to download the .iso file of the exactly same windows version, where inside you can find the folder /sources/sxs/

    You will need to share this folder with the VM to copy it somewhere (or use a USB), I copied it on disk D.

    Then you need to open cmd with administrator privileges and run the following command:

    "dism /online /enable-feature /featurename:NetFX3 /all /Source:d:sources\sxs /LimitAccess"

    where you can see, you source the folder mentioned.

    I did this and afterwards the EthernetKRL_Server.exe started to work.

    Hope this helps!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners