Advertising

KRC2 ED05 Error

  • Hi All


    I'm having trouble with my KRC2 ED05 cabinet. Every now and then I get a few errors appear on my pendant which causes me to not be able to jog the robot at all. It is very intermittent. It will be fine for 5-10minutes and then the errors appear.

    The errors are;

    Ext. Emergency stop pressed

    and

    Unknown operation mode.


    These seem to go hand in hand.


    These are the things I have checked/replaced;

    KPS x2

    Pendant

    ESC board x2

    Re-checked Shorting plug

    Looked for damage on pendant loom in the cabinet.


    Any ideas would be so grateful


    Thanks in advance.

  • AD
  • Hi SkyeFire


    I have checked connections into the ESC board when I've swapped it to another board. Made sure every connector went in flush and no pins bent.


    To get out of it, I either have to reset the ESC board with the button on the board itself or do a complete restart on the cabinet.

    I'ts very strange.

  • i find it more strange that people ask for help without specifying important details.

    "it is an "ED05 cabinet" is not very specific. i have so 50 wiring diagrams for ED05 and different CI3 boards.

    roboteam ready cabinets with CI3 tech board could have CI3 powered externally and connected to other cabients via KIR.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hi Panic Mode


    I'm sorry, I did read that post first, I'm just very new to Kuka and not sure how to find some of the information it said to include in my thread before I posted it. I don't know anything about them, hence why I am on here looking for help. The only reason I knew it was ED05 was because it says it on the computer in the cabinet. If I knew how to find this information then of course I would have included it.


    Sorry if I don't know enough to qualify asking for help.

  • then just describe it a bit. how many axes, with or without top cabinet, standalone or part of a roboteam.

    if unsure take picture of the ESC board(s), teachpendant, cabinet label, cabinet connectors, drives.

    there is a pinned topic called READ FIRST which should help narrow it down a bit on what would be helpful.

    and those "few messages" should be captured too. we are not mind readers.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Independientemente de detalles específicos de tipo de armario, yo chequearia los 2 canales de seguridad de la emergencias externas. Posiblemente, 1 de ellos se está abriendo o Chopeando. La esc detecta parada de emergencia pero como solo es de un canal, pierdes modo de funcionamiento T1, T2... Si el robot está en una máquina, monta conector de seguridades X11 de puente de seguridades y verifica si el error desaparece. Si es así, tu problema es externo al robot. Verifica cableado externo como contactores de seguridad externos.

    Un saludo.


    Google Tranlation:

    Regardless of closet type specific details, I would check the 2 security channels for external emergencies. Possibly 1 of them is opening or Chopeando. The esc detects emergency stop but since it is only one channel, you lose operating mode T1, T2 ... If the robot is in a machine, it mounts the safety connector X11 of the safety bridge and checks if the error disappears. If so, your problem is external to the robot. Verify external wiring such as external safety contactors.

    Greetings

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now