Advertising

Kuka Krc2 v5.5.16 - Arrays TouchUp

  • Hi,

    i have in company Kuka Kr30 with KRC2 v5.5.16 and i have installed ExpertTech. I try to TouchUp points which i have declared in .dat file as E6POS arrays, and when i select this point in .src file and put TouchUp button i get message "unknown module". But when i write some values for this point in dat file i can move robot to this points in src. Maybe know You what i do wrong ??

    ( i use the same function in older robot v 4.2 and everythings works fine)

    e.g


    DEFDAT PROG1


    DECL E6POS POINT[5]

    POINT[1]={X 0.0, Y 0.0, Z 0.0, A 0.0, B 0.0 , C 0.0, S 0, T 0, E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0 E6 0.0}

    POINT[2]={X 0.0, Y 0.0, Z 0.0, A 0.0, B 0.0 , C 0.0, S 0, T 0, E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0 E6 0.0}

    POINT[3]={X 0.0, Y 0.0, Z 0.0, A 0.0, B 0.0 , C 0.0, S 0, T 0, E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0 E6 0.0}

    POINT[4]={X 0.0, Y 0.0, Z 0.0, A 0.0, B 0.0 , C 0.0, S 0, T 0, E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0 E6 0.0}

    POINT[5]={X 0.0, Y 0.0, Z 0.0, A 0.0, B 0.0 , C 0.0, S 0, T 0, E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0 E6 0.0}


    ENDDAT



    DEF PROG1()


    INI

    ......


    PTP XHOME

    PTP POINT[1]

    PTP POINT[2]

    PTP POINT[3]

    END

  • AD
  • hi,

    thanks for you replies. Yes i tried use arrays as end point for robot move and in older version( like krc v.4.1) in src file when i select line where is this point i can overwrite it using touchup button and everytngs work fine. I have reinstaled ExperTech again and now i don't get "unknown module" fault again, but when i use touchup button nothing is happend, no messages and no point data changes

  • here is part of working fine program in krc v4.1



    and when i try use the same way in krc 5.5.16 its not working

  • when i try create simply program like only few end points like e.g.


    src file


    DEF PROGRAM1()


    INI

    $TOOL=TOOL_DATA[1]

    $BASE=$WORLD

    $IPO_MODE=#BASE

    $APO.CDIS=30

    $APO.CPTP=90

    FOR I=1 TO 6

    $VEL_AXIS[I]=50

    ENDFOR


    PTP XHOME


    PTP POINT[1]

    PTP POINT[2]

    PTP POINT[3]


    PTP XHOME


    END



    DAT FILE

    DEFDAT PROGRAM1()



    DECL E6POS POINT[5]

    POINT[1]={x 0.0,y 0.0,z 0.0,a 0.0,b 0.0,c 0.0, S 0, T , E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0, E6 0.0}

    POINT[2]={x 0.0,y 0.0,z 0.0,a 0.0,b 0.0,c 0.0, S 0, T , E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0, E6 0.0}

    POINT[3]={x 0.0,y 0.0,z 0.0,a 0.0,b 0.0,c 0.0, S 0, T , E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0, E6 0.0}

    POINT[4]={x 0.0,y 0.0,z 0.0,a 0.0,b 0.0,c 0.0, S 0, T , E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0, E6 0.0}

    POINT[5]={x 0.0,y 0.0,z 0.0,a 0.0,b 0.0,c 0.0, S 0, T , E1 0.0, E2 0.0, E3 0.0, E4 0.0, E5 0.0, E6 0.0}


    ENDDAT


    Earlier when i selected any line with end point in src file, when i pushed TouchUp button i got "unknow module" message . But now after i reinstalled ExpertTech when i select the same lines in program and try overwrite it using TouchUp button i don't get any error messages and and nothing happen

    no DIALOG QUERIES as a "do you really want to touch up point[1]" or something like this;/ and data of point are not overwrited

  • and when i declare any position data ( different than 0) in dat file i can move robot to this position, but i can't overwrite it using TouchUp button

  • I honestly don't recall ever seeing TouchUp work with array points. I know it never worked on any robot of mine. But, I never had ExpertTech.


    Is the version of ET on your new robot correct for KSS 5.5? Or did you copy the ET installer from KSS 4?

  • HI,

    in KSS 4 i don't need ExpertTech, everything working without it, for KSS 5.5.16 i got it from integrator who sold this robot to the company where i work.

  • yes I see it here, but when i open HELP-> FUNCTION You can see what additional function You have installed in robot. And in KSS 4.1 this window is empty and in KSS 5.5 i see what i have installed earlier. I think (but im not sure) in older KSS you don't need install these all function, everything is there as a standard.

    So, why if i have installed ExpertTech in KSS 5.5 i can't do that in the same way?

  • HI,

    today i'm going back to my problem :/ And i'm seeing something weird (for me). I have installed Expert tech in my Kuka KSS 5.5 but when i try touch up any endpoint in src file i don't see TPEXPERT in messages (as in KSS 4.1) , everytimes i see TPBASIS. Can i change it maybe?

    That is because your are touch-uping INLINE form... Points in RED use TPBASIS... ExpertTech is used for points in raw KRL (black) ...


    Do you have any other version of ExpertTech and try with that... Maybe KUKA forgot to include that function for the arrays from KSS v4.1.7 SP08 on Win95 in newer ExpertTech packages...

  • Hi,

    i have only one version with experttech, i have tried to unistall it but this function doesn't work i don't know why because i do everything in the same way as in manual

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now