Fanuc S-420iW, RJ2, no system software - need help :(

  • Helo.

    We have a big problem with one of our old arc welding robots. Everything was working fine, until yesterday after a power outage we have no system software on the robot :( After power on, we have only the boot monitor screen as in the photo. Unfortunately we do not have the original system installation disks and the old CD with controller backup is not working (we have tried in a couple of different computers :(

    We have only this one iW version, our other robots are the S-420iF, so we can not use backups from those robots :(


    Does anyone have a controller backup image for this very old robot and can help us ? We need the S-420iW, R-J2, ArcTools (with must have the Weave option for this system). We can manage the reinstall on our own (can use the SRAM cards or kfloppy).

    Please send to: piotr@buczynski.eu if possible.


    Best regards

    Piotr Buczynski

  • AD
  • Have you tried to restore the software from the screen in the image you shared with options such as INIT START or CTRL START again? Sometimes CTRL START can work when you experiment by taking a little extra time. I think with a few tries, don't give up right away. I have an old solid image file for the RJ2 S420IW. I backed it up from a system that was running smoothly. But I remember there was no arc-Mate feature. As I recall, he only had a Profibus card on him. This robot was welding, but I did not need the arc-Mate feature, a normal profibus module later introduced the robot and used the welding machine input-output options in the program. I don't know if you could use the image files.

  • Helo.


    I have tried the COLD, then CTRL, then INIT start. There is a message "No system software". Today I have loaded the system backup from other robot - iF version to test if the robot is functional. Everything works, but the robot will not travel in a straight line. I think the iW has different reducers than iF and the image from iF will not work. Or is there a way to change the motor and geometry parameters of the installed system (I think not possible) ?


    Unfortunately for the work we do (welding big, thick 10mm parts) we need the Arc Tool with weave option. I think it will be cheaper to buy a new robot than get the new system software from Fanuc :(

  • They are in UK and they specialize on used robot parts and used robots in general. They also have different CPU configurations. They have everything needed to get a robot system up and running in no time. I have purchased a used robot from them in the past and they loaded all the software options I needed for my application. They also forgot to load Handling Tool and they sent me another CPU with the correct options.

  • Você tentou restaurar o software da tela na imagem que você compartilhou com opções como INIT START ou CTRL START novamente? Às vezes, CTRL START pode funcionar quando você experimenta, gastando um pouco mais de tempo. Acho que com algumas tentativas, não desista imediatamente. Eu tenho um arquivo de imagem sólido antigo para o RJ2 S420IW. Fiz backup de um sistema que estava funcionando sem problemas. Mas lembro que não havia recurso arc-Mate. Pelo que me lembro, ele só tinha um cartão Profibus com ele. Este robô estava soldando, mas eu não precisava do recurso arc-Mate, um módulo profibus normal posteriormente introduziu o robô e usou as opções de entrada-saída da máquina de solda no programa. Não sei se você poderia usar os arquivos de imagem.

    Hello Byrol, how are you? I need an image backup of this robot, do you still have it available? Another doubt, can I restore this image through the memory card that fits in the PSU?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now