Help with Fanuc R30ia Ethernet ip setup with PLC

  • Help Needed!


    So I have have looked at about every post on this forum about Ethernet ip setup and have set it up on a Kawasaki robot no problem.


    I am trying to ethernet/ip connect to an automation direct PLC P1000 as I mentioned I have done this with the exact same model plc with a Kawasaki robot.


    My robot is and Arcmate 120ic R30 ia controller with Arclink Ethernet (Port 2)


    I have set up the Host communication and am getting a successful ping to the plc ethernet port but I am not getting any communication on the ethernet ip side. I also have tried a generic client in the plc and have used a Fanuc ESD file. Along with that i have tried several different IP addresses and subnet mask addresses. I have attached pictures of the setup in the robot and plc. I'm sure that i am missing something but for the life of me i cant figure this one out. Thanks for any help anyone could provide!


    Also the reason I am wanting to do this is for some UOP and Digital signals so i can control through an HMI.



    Also on the Client I have tried using 10.10.1.3 and 10.10.1.2 still no connection and all different types of 1d Arrays 16-32 with no luck




  • AD


  • Here is a picture of the ethernet ip config screen. I have the connection enabled here. When i try to ping from this screen I get an error at the bottom that says invalid host


    I'll have to double check but i know port 2 which is the Linconln welder ethernet port is 192.168.34.5 and subnet mask is 255.255.255.0

  • Also I haven't tried to uncheck the status header check box. I'll give that a shot but i thought i read it needed to be checked. My main concern was if i had it correct with 16 bit 1d arry and 4 elements. Everything that I read in the manual said it needed to be that.

  • Thanks for the help i really appreciate it. I have tried using the same IP and i have the ethernet port set up as and it didn't work. I did read that you cant use the same subnet mask on both ports so thats why i change it to the 10.10.1.2


    I contacted fanuc and they asked if i had Option R 507 ASCII Upload Option. I'll check that tomorrow also. I have seen people on here get them to connect so really I just wanted a fresh set of eyes on it to see if my setup looked ok.


    If i cant get this to work i may just end up going with a safety controller that can handle it all.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now