Advertising

KSS Error in KUKA KRC4

  • Hello guys! All right?


    I have 2 robots that are having the same problem.


    KSS intermittently closes and I can't open it anymore. When that happens, I have to put a screen on the outside with a mouse and keyboard to be able to restart the robot.


    The problem occurs in robots with KSS V8.3.7 and V8.3.8.


    When an error occurs, the smart pad screen looks like the one below.

  • AD
  • It looks like HMI crashed. how long it runs before this happens? do you reboot and how often? what type of start - cold start or hibernate? you can take KRCDiag and send to Kuka


    at any rate, personally, i would make full backups then try upgrading KSS to something newer, at least 8.3.15, preferably 8.3.34 or so. this should bring many little fixes and improvements. as long as first two number are matching the cabinet sticker (major version KSS8.3), you don't need to worry about license.

    if you run into any trouble, just restore.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Counterspeller

    Changed the title of the thread from “KSS Error in KUKA KRC4 Error” to “KSS Error in KUKA KRC4”.
  • It looks like HMI crashed. how long it runs before this happens? do you reboot and how often? what type of start - cold start or hibernate? you can take KRCDiag and send to Kuka


    at any rate, personally, i would make full backups then try upgrading KSS to something newer, at least 8.3.15, preferably 8.3.34 or so. this should bring many little fixes and improvements. as long as first two number are matching the cabinet sticker (major version KSS8.3), you don't need to worry about license.

    if you run into any trouble, just restore.

    Hello Panic Mode! Thanks for help!


    The robot is currently running in a cold start. It causes the robot stop only when there is an anomaly in the cell (no signal, etc.) not referring to the KSS close. Do I have an image of the KSS 8.3.39 version, if I use it on this robot will cause a problem?

  • anything can cause a problem, specially when there is a lack of planning and preparation.


    but problems can be minimized by doing right steps such as making backups (yes, more than one).


    at least archive and image, preferably also WoV project and KRCDiag and all options from D:\


    some info is redundant among those backups but depending on what you are dealing with, each can have some advantages and if one of them is corrupt somehow, you will have options out of the situation. the thing is you will not know for sure if some backup is good until you try it.


    also if the image is from another robot, i would advise to not use it on this one. options, configuration etc could be different and you don't want same SID on two robots.


    note, KSS upgrade will try to keep all programs and settings as they are.

    KSS new install will wipe them all out.


    i would make backups and then upgrade this robot with newer KSS. some upgrades are fussy and i have seen robot not moving to new KSS without some "convincing". in that case rename D:\KRC_Relase to D:\KRC_Release_old. then place D:\KRC_Release from the image you have (you can extract this folder using 7zip).


    this way upgrade should work every time even on fussy ones...

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Okay, I have an image that was passed on to me by a kuka technician, it is meant to be factory. To solve this problem, I will make a current image of the robot and also a backup, then I will pass the image 8.3.39 from the factory and restore the backup, I believe that this way the problem will be solved, if it does not happen, I have the previous image as a backup .

  • if using factory image, you need to install previous tech options and then deploy and activate previous WoV project after setting version to match new KSS

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • if using factory image, you need to install previous tech options and then deploy and activate previous WoV project after setting version to match new KS

    The image that the kuka technician gave me was corrupted, the Robot that is having the error on the smartpad is old, with KSS 8.3.8, but I have a robot that came to me last year with KSS 8.3.39. Can I use the image of this robot? I would use the backup instructions you commented on in the posts above.

  • not recommended. that image is already finalized so donor and recipient machine will have same SID and will not be able to network with each other.

    hello everyone :)

  • yes, when windows is ok, there is no requirement to reload image.

    corrupt KSS can be restored by reinstalling KSS and option packages.

    if both windows and KSS are ok, system restoration only needs deploying and activating WoV project (if complete).


    restoring backup image is a convenient way to bring everything back to a known state quickly.

    but having multiple options is never an issue so multiple forms of backup are advised.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now