Troubleshooting KRC4 Compact _ KR10 R1100 Sixx Agilus

  • Dear Admin,

    I am commissioning KRC4 Compact controller, KRC V8.3.32 with KR10 R1100 Sixx Agilus Robot. I have some errors during startup and can’t even start the Robot in IBN modus.


    Errors:

    1) No Connection to RDC Possible

    2) Confirmation of safety configuration required

    3) EtherCAT device KUKA servo pack not connected to bus

    4) Workspace monitoring functions deactivated

    5) No Robot number programmed

    6) Safety Stop

    I have already tried the following points:

    1. Physically check cabinet for loose wiring and broken pins in connectors. Everything looks okay.
    2. Wired X11 and tested it. It looks okay.
    3. Tried installing Base project that comes with Robot. But the errors still persist.
    4. Tried activating safety configuration with different settings but no success. It gives red error stating that ‘Safety configuration could not be activated’
    5. Went through the KUKA Roboter Forum for solutions but couldn’t find necessary info.
    6. Checked for RDC folder in Windows but this folder didn’t exist. It also says ‘Suitable mam file doesn’t exist - error8’

    Can someone please help me on how to proceed forward. Thank you.

  • Place your Ad here!
  • #s 2,4, and 6 are side effects of the other errors. They can be ignored for the moment.


    #1 suggests the connection from the cabinet to the robot is incorrect. The RDC is located in the robot base, and is connected with the smaller of the two KRC-Robot cables.


    #3 I'm not certain about. But it could actually cause #1 under some circumstances. The KRC uses an internal EtherCat network, and if this were to fail, communications to the RDC and the servo pack would both be lost.


    #5 I would check STARTUP> Robot Data. If this does not show a serial number for the robot, this again suggests that the connection to the RDC is not working.


    Is this a brand new robot?


    I would recommend comparing the values of $ROBTRAFO[] and $TRAFONAME[] -- I once had some brand-new robots where these did not match, even with the robot brand-new from Germany, and had to set $ROBTRAFO[] to match $TRAFONAME[] in order to clear the MAM errors.


    But I think your best bet is to pull a KRCDiag and send it to KUKA Tech Support -- there could be a configuration issue in the WorkVisual project, but if so, it's in the fiddly hardware details, and would be very hard to diagnose in the forum.

    • Helpful

    this is fairly recent although not the latest KSS. this tells me that robot must have been already in use. what changed?


    i hope you did not get the idea to create WoV project from scratch. Although WoV is improving this is something that should be left to those with intimate knowledge of WoV. It is MUCH better idea to get working or base project from controller and adapt it, than trying from scratch. Note, when WoV project is deployed, if changes are significant (involve hardware or safety) they will affect safety checksum. This means that after deploying and activating new WoV project one still must activate safety portion too (this is a separate step).


    i would say make backups (archive, KRCDiag and Image of HDD), still better now than never.

    then see if there is previous project that can be activated, if not check D:\


    if WoV project was not modified or replaced, unless HDD got corrupt, problem is hardware:

    * X21-X31 cable bad or not connected from controller to robot base or .. not connected correctly (check for bent or pushed out pins on both ends). missing or damaged O-ring can cause intermittent problems.



    * blown fuses (check CCU)

    * dead RDC

    * different robot arm attached to controller

    * USB cable not connected to PMB

    * One or more of network cables not connected or not latched or possible connected to wrong port (each must plug into EXACT place, must not mix them).

    * defective CCU

    * defective KPP/KSP (accessing those is not advisable, they are in the bottom compartment and open frame and require care).

    etc.



    Note:

    always read messages that started it all. look at the time stamps. most of other messages are "supplemental" and could be even misleading. in this case message on top is the last one. while it is correct, it is just timeout and can be acknowledged. note that it's time stamp is significantly later.

    oldest message show telling that robot number is not programmed is telling cooner that it cannot get data from RDC. which resulted in safety stop and workspace monitoring.


    next one tells that problem is on KCB (Kuka Control Bus) which is network controlling motions. It connects RDC, KPP, KSP, RDC with KCP. message suggest that KSP061 is not reachable but this is not necessarily the problem. if any of the nodes is not connected, entire bus is dead. hence i would suggest to check really closely fuses and connector of X21-X31 cable.


    next message is confirmation of safety configuration. so some hardware is changed or not detected or there is a conflict (wrong FSoE address) etc.


    reason i mentioned to make different backups is because they are all different and contain info not contained in other backup types. for example KRCDiag will only collect working WoV project, not others (if present). this hinders remote diagnostics somewhat since it prevents comparison for example. But KRCDiag collects a lot more other info not contained in archive or image.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • SkyeFire : Thanks for the help. This robot is sitting idle for last two years and may be a total of 3 working hours with this robot. It's working fine before two years and when it is taken out of inventory for recommissioning, I got these set of errors.


    panic mode : Thanks for the help. I sent the diagnostic file to KUKA and they said that they have to replace KSPsr and surprisingly didn't mention anything about RDC. I am scheduling an appointment shortly. Once this problem is solved, I will write in detail about what KUKA technician did, the existing problems and solutions.


    Thank you once again:thumbs_up:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners