Advertising

Fanuc iRVision Off-Axis Rotation Correction

  • I am working on an application where the TCP picks a part from the nominal center, however the offset information is provided based off iRVision locating a feature (Green Box). Since the locating feature differs from the pick point in both the X and Y direction, any rotational changes of the part significantly throw off the X and Y of the pick point.


    The EOAT is a simple suction cup with the Tool frame only containing the Z element.


    I will always know the theoretical X and Y distance between the locating feature and pick point. Is there an easy way to rotate about the axis of the locating feature while maintaining accuracy of the pick point orientation in all directions?


    I have tried several things and gotten close, however it needs to be much more accurate.

  • AD
  • It should handle this situation without issue if it is setup and calibrated correctly.


    How did you calibrate? Robot or fixed mounted camera? How did you teach the grid frame? Show images of your vision process settings. Show your tp code.

  • It is a fixed mounted camera and calibrated to a single plane. Normally I calibrate using a automatic grid frame set, however I could not fit the robot/calibration grid into the required area of the cell. See attached vision process, calibration, and TP images.

  • It seems that you are missing where you select your offset user frame in the vision process menu. Normally that selection is underneath where you select the offset mode, which is set to fixed frame offset. Is this an older controller model? I know that if the robot doesn't have the correct offset frame selected that matches with the Part Z height then your positioning accuracy will be bad.


    When you took a picture of the grid, was the grid sitting on top of the part or at the base of the fixture?

  • This is on an R30-IA controller (About 2013), I noticed the missing User Frame selection in the vision process as well. We have the newer R30-IB and R30-IB+ controllers as well that both show that option.


    When I took the picture of the grid it was on a spacer bringing the Z height to that of a part in the fixture.


    I am also going to try and 3D print a different EOAT/Calibration Grid holder that can get me in the area I need to do an automatic grid frame set. This is how I've always calibrated cameras and never had issues.

  • So on R-30iA, there is no separate selection for offset frame. It uses whatever you have selected for Application frame. In that case it sounds like your Z height should be correct.


    I think something must have gone wrong while teaching the grid frame or calibrating the camera.


    Here is a list of things to try.
    1. make sure have a well taught TCP for your pointer. Reteach if needed.

    2. With that pointer set as the active tool frame, reteach the grid user frame, and compare to what you had before. You must use the 4 point method for this. If the grid is not on the part surface, then measure the difference in Z height.

    3. With the grid in the same location, re-do the calibration. If the grid moves at all between step 2 and 3 you must start over.

    4. Reteach the reference position

    5. Reteach the point in your TP program.

  • Late to the party, but here is a trick i use sometimes. If it is a fixed mounted camera and you do not have space to run the automatic grid (tool) frame set, you can temporarily move/mount the camera in a location that allows you to run the automatic grid (tool) frame set utility. Also, because you are running older software version I think it allows you to put constraints on the amount of x and y movement during the auto grid frame set, new software only allows you to constrain W,P,R and Z.


    Some people get confused by this, but keep in mind camera does not need to be calibrated to run automatic grid frame utility. I heard there used to be a utility that would allow you to plug in a usb camera strictly for assigning tool frame for robot held grid, again only heard of it, old man lore back in my day kind of thing.


    Also nice to have an extra GigE camera just for setting up tool frames, that way you do not have to worry about moving existing cameras around.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now