WinC5G pc to controller

  • Time for me to throw another post up. I find comau's to be very user unfriendly sometimes.

    My new question is the proper procedure to connect the controller to my WinC5G software. the manual says to login with administrator privileges, and match the ip adress to the one on the APC board. However it hasnt worked for me, so my two theory's are that 1. what i believed to be the APC board (anyone have a picture of one) is in fact not, or 2. i need a full version of WinC5G and im not sure if i have one.

    Any suggestions or assistance would earn a small lifetime of gratitude.

  • Place your Ad here!
  • You can connect You PC to robot controller with basic WinC5G, but the ip adresses should be in the same subnet, but the last octet should be different.

    Unfortunately, I don't have a pic of an APC board right now.

  • ive followed the steps in the manual, and what was mentioned above. However I am unable to connect to the controller. i get an error saying a connection with the server could not be established.


    I have found my ip adress under the network screen of the setup tab. connected my APC board to my pc. Assigned the Ethernet connection the appropriate Ip adress and matching submask. and changed the c5g library to match my system, i believe it was 2.4. But i still get that server error.


    my Lan connection says i have no network access, could that be my problem. How would I go about fixing that?

    Edited 2 times, last by TheNewGuy ().

  • Well, if You don't have network access, thats is probably the cause. You can try to change the cable, ou check you lr LAN card with other equipment.

    But You also can check:

    Can You ping the APC through Windows CMD?

    What is the WinC5G version You is using?

    And what are the credentials (usename + password) You is using to connect to APC? If is a running robot, maybe someone changed it from default values.

  • Ive used the cmd window to ping the ip adress, and it does say that its communicating. The credentials that im using are general access so username ga, password ga, its set up with all the privileges.

    my WinC5G is version 2.40.7. Im sill getting that same pop up, it cant connect to the server.

  • hello,

    yes i did, i have the WinC5G working now, I am now just curious as to why allowing a seemingly random thing through my firewall would solve the problem i was having. it was the distributed transaction coordinator that was blocking my connection.

  • Hi,

    I'm having some troubles to start using the software. I got a DVD with the installation files but without instructions. So I'm asking you if you could send me the PC software manual, and how to install it.

    I will send an image of my actual situation.

    I need to understand How to define new I/O and ethernet communication. And how to use the software in general because I need to program offline for some time.

    One more question: is there any simulation tool for Comau?

  • Hi. margaor

    As far I know, WinCRC doesn't have specific manuals, but You can find instructions for it on robot Control Unit Manual (le-rc-c5plus-uso-tp5_en.pdf, for example), on a chapter called USER INTERFACE.

    You can define some I/O configurations on a file called <YOUR_ROBOT_NAME._sys.cio, that can be edited on WinCRC as well, but to configure the bus on the real robot You will also need a software called SyconNet. If You have COMAU DVD, you probably have the installer.

    COMAU has two simulators. One called Robosim, for C5G generation of controllers, and a newer one, called Roboshop, for the C5GPlus generation.

  • Hello,

    Looking at your pictures, I think you have one of the first versions of WinCRC, that has libraries only for C5G+ with software 3.10 and 3.11. This version will not open files created on a C5G+ controller with 4.11 software, but you should be able to open some .cod files created with previous versions of the controllers.

    You can ask COMAU for the newest WinCRC, with all C5G+ libraries.

    The best course would be WinC5G and WinCRC installed side by side on the same computer. You must observe that Windows will associate all COMAU files with the last software installed. So if you install WinC5G lastly and double click on a C5G+ file, WinC5G will try to open it, and will give a fault. In this case, you must open WinCRC first and open the program from within its interface.

    If you have access to the real robot, You can save all programs in .pdl format, and this way You can open them in any text editor.

    Regarding the C3G programs, You need another piece of COMAU software called PDL2.exe, or something like this. Is a command line utility, and I'm note sure if it would work on newer versions of Windows. You also need to observe that C3G require a PDL2.exe version, and C3G+ require another one.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners