Advertising

Excessive segment

  • Hi


    Welding robot DX200.

    In one of the jobs there is a tight corner the robot welds through. I noticed right away when writing the job in MotoSim that there's a lot of axis movement in that corner but there was no other way to go through it as I couldn't stop the weld in the corner and I didn't have any better angle to approach from.

    It workd in MotoSim with the given speed and most of the times it works on the robot as well, but sometimes I get an alarm going through the corner: Excessive Segment [R1:HIGH SLURBT] - R and T highlighted.

    Alarm Reset and restart will make the robot successfuly finish the weld.

    I'm using P-variable (value found with search) to shift this weld and it seems that certain P-variable values shift the corner to where the axis movement is still to great for the given speed . I've seen this before where a linear movement with shift could not be executed with a certain P-variable value, but worked great without it.

    I decreased the speed for the corner - I still get the alarm but not so often.

    Now my question - is there a parameter (or any other way) that could make the robot go through this corner with the maximum speed it can handle BUT not greater than defined by the MOVL instruction?

  • Have you tried adding additional movement commands through the corner? That could help; I've had similar joint errors before for doing large rotational axis changes in one move that were corrected by doing 3 smaller fluid ones. Normally this is fixed with a switch from MOVL to MOVJ but I assume your weld is active so that's no good.

    I also use OLP to make a lot of my programs and they always end up needing changes like this once I load them onto the bot... It's frustrating. But that's just where simulation is right now, I guess.

  • In addition to WhyDoesMyRobotHateMe's idea another possibility, slowing down (I know, cycle time) and changing your arc conditions could help.

    Alcohol: The cause and solution to all life's problems

  • In a 3h cycle, it doesn't really matter if I slow a 3cm weld down. I'd do it right away if I knew the speed at which it can go through the corner with all possible P-variable shift values.

    There is a third option as well - I can just use the P-variable value to shift not the robot, but the base axis (it's a gantry with 3-way base) - that would still shift the weld but would keep the robot movement constant.

    At the moment I'd like to know if there is a parameter (or other setting) that can avoid the Excessive Segment alarm by limiting the speed where needed.

  • I usually can get past these alarms with slight changes in tool z-axis rotations for the start, corner and end positions that decrease the amount of travel for the affected axes, in this case R & T. Slight changes in torch angle and increasing the corner PL may also decrease the amount of joint rotation enough to consistently run without the alarm. I do this before lowering speeds.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now