Advertising

Test LBR Axis in real time

  • Hello,

    I am new here and a junior in robotic world.

    I have Kuka LBR Robot with KR C2 controller. I start the controller all load but want to ask you how I can test each axis of the robot in real time to check if it work properly? Can I have make and selftest to check the condition of the robot if it work properly?


    Thank you in advance!


    Best regads

  • I want for example with the joystick in the right side of the control panel or with the keys on the panel to move each axis in real time manually.

  • In Status window is following information:


    ! 3:59:38 PM 6503 Configuration error I/О driver DN2DRV

    ! 3:59:41 PM 4 Buffer battery voltage low PM1

    ! 4:00:24 Pm 420 KS Local Protective Stop (QE)

    ! 4:00:24 PM 1 KS EMERGENCY STOP

    ! 4:00:24 PM 20 KS External EMERGENCY STOP Pressed

    ! 4:00:24 PM 404 KS EMERGENCY STOP safety controller

    ! 4:00:24 PM 310 KS Safety circuit for driver not ready

    ! 4:00:24 PM 200 KS Drives contactor off

    ! 4:00:24 PM 1034 Error or writting, driver DN2DRV

    ! 4:00:24 PM 482 LR LR: Position-Control

    ! 4:00:25 PM 364 KS unknown Operation Mode (?)

  • Hello again,

    I have read the Kuka instructions and documentation. I have the following error codes when I start the Kuka:

    ! 3:59:38 PM 6503 Configuration error I/О driver DN2DRV

    ! 3:59:41 PM 4 Buffer battery voltage low PM1 <- I have replace the both akku's and now do not show me this error [DONE]

    ! 4:00:24 Pm 420 KS Local Protective Stop (QE)

    ! 4:00:24 PM 1 KS EMERGENCY STOP

    ! 4:00:24 PM 20 KS External EMERGENCY STOP Pressed

    ! 4:00:24 PM 404 KS EMERGENCY STOP safety controller

    ! 4:00:24 PM 310 KS Safety circuit for driver not ready

    ! 4:00:24 PM 200 KS Drives contactor off

    ! 4:00:24 PM 1034 Error or writting, driver DN2DRV

    ! 4:00:24 PM 482 LR LR: Position-Control

    ! 4:00:25 PM 364 KS unknown Operation Mode (?)


    The bolded error codes for the emergency afraid me but I have read the documentation and then is written that I must connect the emergency switch to connector X11. I have with bridge cables simulate the emergency connector as follow:

    Connector X11:

    bridge between Pin1 and Pin20

    bridge between Pin2 and Pin21

    bridge between Pin3 and Pin24

    bridge between Pin4 and pin25


    but without result


    I have connect and external 24V power supply on the same connector X11 on:

    Pin15 and Pin16 - Ground

    Pin33 and Pin34 - 24V supply


    but again without result


    Want to ask you is it possible that this emergency stop to be a software settings or I make some wrong?


    I think that when all this error codes was removed will have the possibility to jog the robot.


    Thank you in advance!


    Best regards

  • Hello Guys,

    I have not answer from you with ideas and issues of my problem with kuka emergency protection and today will try to simulate all possible emergency signals to try to jog the robot.

    To simulate the hardware emergency protection will use the following wiring diagram for connector X11 from the kuka kr c2 dokumentaion.


    If you have other ideas please write me.

  • Hi SkyeFire,

    Thank you for your reply


    We have not supply voltage between Pin37 - 0V ESC and Pin19 - 24V ESC - we messured by power on 0V between this two pin on connector X11

  • That suggests you have a power supply issue internal to the robot.


    However, the LBR is a sufficiently unique system that just using the KRC2 rules/jumpers may not work. I think you may need to contact KUKA tech support on this one.

  • You think that the problem is in the robot (arm manipulator) or in the Robot control box where is the PC, UPS, ESC and other component for control the robot.

  • Its two different wiring diagrams for internal power supply and external on KR C2.

    My controller is: "Type: LC Controller" - is written on the label


    I have try with internal power supply (by me on Pin19 and Pin37 have not 24V) and with external 24V power supply - the result is the same with the same errors.

    I attach the wiring diagrams

  • I have found the right documentation with right pinout and wiring diagrams for my controller.

    Now I have good result - the EMERGENCY mode now work and the ESC Controller have supply now I can diagnose.


    I have other error in status windows that I can not understand where is the problem. I have read all documentation but can not find the needed information. Also the error codes are:


    6503 Configuration error I/O driver DN2DRV

    310 KS Safety circuit for drives not ready

    200 KS Drives contactor off

    1034 Error on writing, driver: DN2DRV

    482 LR LR:Porigion-Control


    This error that are bold marked can not fin information.

  • The "Drives contactor off" is not an error, just a status. When you enable the deadman, that error should go away as the motors energize.


    The "Safety Circuit not ready" message is odd -- I would expect that to happen alongside an E-Stop or Motion Enable error.


    The "Porigion" error I'm not familiar with.


    The DNDRV error could be related to your motion issue -- check the setting of $MOVE_ENABLE. You may need to change it to 1025 (the "always true" input) until you have your external I/O working.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now