Advertising

KUKA.EthernetKRL and OfficeLite

  • Hello, is it possible to use KUKA.EthernetKRL in OfficeLite? I have installed KUKA.EthernetKRL v2.2 in OfficeLite v8.3.28 and cant connect to external system from OfficeLite v8.3.28, always giving EKI00014 "Ethernet connection to external system failed", but i can ping the external system just fine inside the virtual machine where OL is installed, so connection is there...:/

  • AD
  • i did... and yes it works.


    if using EKI to communicate with program running inside OL, just use address 192.168.0.1.


    for communication with external application normally one need to use router. this is a small piece of software that can be obtained from KUKA.


    Note that EKI runs on VxWorks. This is also where KLI port is.

    But in OL there is no KLI so the only option users have is to get access to EKI through RTOS port 192.168.0.1.

    Without router there is nothing to connect that port with the Windows interface that you use to ping outside world.

  • Thank you very very much for detailed post on how to set it up and you took time to write all the info... i will get on to it immediately... just for the info i also wrote to kuka simulation office where i got the OL and they said it can't be used...


    I´m sorry – that´s not possible Ethernet is communicating via KLI (KUKA Line Interface) – this interface isn´t available in OfficeLite.


    But going through all the post in the forum about EKI in OL i got a hinch that it can be done... so thank you again for detailed info on how to set it up and i'm sure this post will come handy not just to me and also for others using EKI in OL


    just because that now i don't have to have robot beside me to test some vision camera with KRL...:thumbup::thumbup::thumbup::love::love::love:

  • @panic_mode showed perfectly how to solve the communication from EthernetKRL acting as a client. The thing I need to do is to make EthernetKRL inside of OfficeLite as a server. Clould you please show how to realize that direction.


    Many thanks in advance

  • I think I solved it with the help of your screenshot myself. Adding a route for the used port and the ip 192.168.0.2 seems to work

  • Hello,


    I followed the described steps, but something went wrong, because when I run the application, the IP that appears is IPV6 and it is not what the program is expecting for.


    The configuration is in the right path, with the right IP address, and I have no idea of what is going on.

    Attached is a printscreen of the cofigurations, if someone has any idea of what I'm doing wrong, please let me know!!


  • when running Application you need to pick correct interface.

    default value is 0 for "Network card interface index" but you need to manually try values 0,1,2,3,4.... until you see message that it is listening on correct IP address


    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now