MODULE FAILED

  • I write to ask for your help. I have a Kuka KR200 with a KRC1 V2.3.24. I had several problems to move it, but finally I could do it. The problem I have now is that my programs send me an error 1327 (LINK ERROR) Reading in manuals and the forum (Error 1327 on KRC1) I find that I need some files but I don't know what files and I don't have the CD to get them out there too.


    Could someone tell me if exist some file tih a list of the files necesaryfor the robot? or could someone send me the files for my robot?

  • So it tells you exactly where the problem is. It is in the Submit interpreter.


    It tells you that submit is trying to link (call) another program but it fails. It does not yet tell you name of that other program but that should be obvious once you navigate to Submit location.


    Even if no further info is shown, open Submit and try commenting out one subprogram call at a time until no errors are reported. Then you will know both where in Submit call is made and what is the name of called program....

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Look panic mode this is a test program where I only declare a variable and it shows me that compilation error the truth I am new in this and it would help me a lot where I have to correct the error.

    I am waiting for your response!

    Files

    • errores .pdf

      (215.39 kB, downloaded 4 times, last: )
  • i am not sure what you are trying to say but...


    problem you mentioned at the being of this tread is that some program linked with Submit is missing or does not compile. what you are showing now is not Submit. is this the program you tried linking with Submit?


    if this is different issue, my suggestion is to start another topic so we don't go back and forth.


    try solving one thing at at time. go to Submit and see what subprogram call is giving you problem.


    about the most recent attachment - read pinned topic READ FIRST and make sure to always post complete view of the screen. if you want to declare new variable, make sure it is declared correctly and in correct place. declaration need to be within file limits, not outside DEF/END or DEFDAT/ENDDAT.

    if you want to declare variable you must be logged in as expert and must act as an expert. that also means to adjust display to show DEF line. and if your declaration is inside SRC file, it need to be before first instructions.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now