Hardware limit exceeded

  • Hi,

    Our Kuka lbr iiwa 7 R800 got outside its hardware limits in 5th axis about 0.7°. I have read few topics about it here and with this topic I was able to run KRF mode. But I cant find master/unmaster buttons. I got into the mastering menu, but there is no buttons. I have found some photo on the internet where there was software buttons aside every axis, but I dont have them there as can be seen in the attached picture (in both T1 and KRF mode)

    Does anyone know what am I doing wrong?


  • are you sure that is the case? how exactly did you get into this situation? was it by moving robot or by deploying software? reason i ask is because everything is red.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • We got the armed installed by Kuka employee and everything seemed to work. I got into this situation by jogging in world coordinates mode on the pendant

  • I have had this issue before:

    To fix it please start a remote desktop or connect a display + keyboard + mouse to the robot, then minimize to the desktop and follow these steps:

    1) Open a standard cmd window

    2) Type puttytel -vio, this will open PuttyTel, click YES if a dialog appears

    3) Enter the command SRThinMMAdmin_setPositionReference x,0 in PuttyTel and confirm with Enter. Observe upper/lower case (x is the axis index - stands for axis 1 and 6 stands for axis 7)

    4) Move the affected axis to its mechanical zero position

    5) If the axis has independently mastered itself, it must first be unmastered

    6) Then master the axis

    Hope this helps

  • Tried your method, but did not work... In attachment is picture with error i get

  • Hi everybody!!

    Had the same issue today with the 7th Axis but had errors with: SRThinMMAdmin_setPositionReference x,6

    Solved with:

    SRThinMMAdmin_setPositionReference 6

    Thanks for all

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now