Advertising

Setup on Windows for KUKA

  • Hello guys,


    I have a Kuka IIWA 14 R820 with a KR C4 controller, KSS 8.3. Recently, i start to configure the robot trying to make a ros node following this tutorial.


    I made IP configuration, but when i rebooted the controller the communication with HMI not started and the robot has disappear in the interface. And now i can't acess smartPad and Controller are not showed in smartHMi Software. Even after making The reverse Operation to undo the changes made. So, i am searching ways to configure or restore windows standard configuration to KUKA and reinstall the robot that apparently is connected to controler PC but not showing up.


    Sorry for possible english mistakes.


    Many thanks in advance! :)

  • manual changes may lead to more automatic changes that are done by software.

    reverting manual changes often does not reverse automatic changes.


    proper way to try things out is to use KUKA Recovery Stick to make proper controller backup.

    then if and when things don't work out, one can at least revert all changes to previous state.



    Just on a side note:

    IIWA is not using KRC4 controller, it uses Sunrise Controller (which has some similarities with KRC4 Compact)

    Also it does not use KSS, it runs Sunrise OS (which has no similarities with KSS).

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now