XMWIRE function

  • Hi to all.
    I'm trying to use XMWIRE function for wire length check.
    Robot is standing in one position in 13mm from a working part.
    After xmwire command the robot retracts wire and after that begins inching wire, but doesn't stop inching after touching the working part.
    There is no any errors during program execution.

    Do I need any additional option activating or something else?
    Could you, please, give for me some recommendation?

    XAC and SSENSING commands are working correct.


  • From backup, the touch sensing option appears to be on, so I think nothing else is required.

    Not 100% sure but something to check:
    Touch sensing dedicated output is being turned on from robot at point of XMWIRE execution: from your backup is output 115.
    Weld set is seeing this and then provide current for detection (may be setting also in weld set to look at).
    Then when weld set detection current flow, weld set then send output to robot input at correct time.
    Touch sensing dedicated input is being received: from your backup is input 1114.

    Manual states you should receive error after 5s if detection not seen in time.
    Are you saying, you receive no error and robot sits there feeding wire indefinitely?

    I think as dedicated signal, also requires level edge change (from low to high), maybe there is also timing problem between IO exchange.
    Strange as you do not receive error though.

  • Thank you very much for your message.
    Main problem I think is that XMWIRE command turn on TOUCH SENSING signal (115) only for max 0.3-0.5 sec, not constant as XAC and SSENSING do.
    May be I need to activate any additional switch?

  • So are you not even seeing an error?
    Is it just feeding wire out and doing nothing else?
    Are you moving to that location first with a high value accuracy? - maybe sync is starting too early towards.

    Yes, I think this should stay on longer than that, for upto 5s.
    ie waiting for the current feedback from weld set, then error.

    Is it possible your signal from weld source is only a pulse and robot is seeing it early?

  • Hi.
    There are no any errors at all, just feeding wire and ding nothing else.
    I tried different kinds of movement, but...

    I tried to touch the work part with wire and turn on XMWIRE, but it only was feeding the wire for 3-5 sec (without errors). And I saw the input signal of touch sensing for 0.5 sec.

    I'm thinking about changing the AS software.

  • What is the status of your output signal to the weld set during the process?
    Can you adjust the period the output from weld set is on, it maybe that the pulse it's sending out is too short perhaps.

    Otherwise, yes if you are on early revision AS, maybe worth reporting this to Kawasaki and they may advise this as a 'bug' which is resolved in a later version.

  • Do You use Fronius power source?

    I have the same issue, in old TPS and earlier TPSi firmware - if You use two signal at the same time -, xmwire function forces it (- wire inching and touch sensing - ) Fronius firmware gives no voltage on wire...

    For me the solution was to write own function using XAC command - I'm going towards the "Z" axis from the tool direction, if the height is OK - I'm going to weld, if the height is NO OK - going to the cleaning station and cut the wire to the desired height.

    If anyone has a better solution, I would be grateful for the idea.

  • Hello,

    I was wondering if you could help me with the same issue but slightly different. I had the touch sensing setting for my robot turned on by a supplier through a backup they modified and I can now program points with wire check. When I run a wire check program in repeat mode I get the E6516 wire check failure as the wire extends during the 5 sec period touch's the material and then keeps trying to inch like nothing was in its way. I'm wondering if the inputs and outputs of the system are not fully connected or setup. I can see that the wire from the welder is connected to the controller so it at least has that connected. Thanks in advance.

  • When the robot executes this command - ie:

    - at the start of the motion for the first 0.5s, wire retracts at the retract speed.

    - when the position is reached, the wire is then extended at the inching speed.

    - the wire extending will extend for a period of 5s before the error is produced if not detected.

    - when the wire touches the part within the 5s it skips to the next step.

    When using BLOCK programming, it is usual to use the:

    - 1TW and 1GN board.

    - Use dedicated inputs and outputs for IO exchange between Kawasaki and Weld Power Source.

    - This will then invoke the relative signals at the correct part of execution.

    Your backup contains no information relative to your IO exchange between Kawasaki and Weld Power Source, so specific signals I cannot advise except if you are using Klogic as your IO exchange instead, then:

    - What output is telling the Weld Power Source to touch sense (what is being sent from the Kawasaki).

    - What input is telling the Kawasaki current is flowing (what is being sent from the Power Source).

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now