communication error in KRC4

  • Hi to everyone, kuka controller is not getting ON. I listed the error below.
    On startup the errors displayed are:
    1. EtherCAT communication timed out. packet missing.
    2. IP address request failed. cannot request IP address.
    3. could not set IP address. unable to configure IP address automatically.


    To check the problem I tried connecting monitor,but its showing no signal available.


    what maybe the possible problem?
    How to fix the problem?
    Or If possible to take remote from the controller? explain in which port I have connect and which IP address i want to use?


    Thanks and regards
    Santhosh

  • Place your Ad here!
  • Monitor must be connected, correctly configured (input selection) and powered on before power is applied to KRC4.



    If it still shows nothing something is wrong with the KRC4.



    Maybe blown fuse or dead PSU or most likely dead motherboard

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Remote connection is not possible in this case as the communication, IP address setting are not ok. The usual way is to check with monitor. The monitor must display something. Has this controller functioned before? Have you recently changed a component in the cabinet?

  • If the robot's IP address is known, you could connect an external computer to the KLI port and try pinging it. If that works, then the issue is limited to the SmartPad, or the KRC4/SmartPad connection.


    If the ping fails, that (along with the monitor and SP failure) suggests that the KRC4 is simply not operating.


  • If the robot's IP address is known, you could connect an external computer to the KLI port and try pinging it. If that works, then the issue is limited to the SmartPad, or the KRC4/SmartPad connection.


    If the ping fails, that (along with the monitor and SP failure) suggests that the KRC4 is simply not operating.


    Yes sir, i tried with external computer also. its not showing as connected in network connections also its not pinging.


  • Remote connection is not possible in this case as the communication, IP address setting are not ok. The usual way is to check with monitor. The monitor must display something. Has this controller functioned before? Have you recently changed a component in the cabinet?


    Yes, this is 5 years old robots. I have this problem only from last 2 months. but 3 months before I reinstalled some optional packages. after only I am getting this problem.

  • Installing new option packages could potentially stop KSS from starting, but should not prevent Windows from booting.


    The fact that the external monitor does not even display BIOS during boot suggests a hardware issue. Either the main computer is not receiving power, or the motherboard is damaged. I would suggest swapping the main computer for one from another robot. If that boots, the issue is probably in the hard drive -- this can be tested by swapping the hard drives and booting again.


    OTOH, if the computer works properly in another KRC4 cabinet, that tells us that the issue is probably in the power supply of the failing KRC4.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners