Reset additional axis position

  • Hello. I need to programmatically reset the position of the additional axis.
    I tried this:



    I changed the value of variable $brk_mode from B1010 to B1101 in mada


    Program code:
    $async_axis='B000001' ; to make the e1 axis asynchronous
    wait sec 1
    $async_ex_ax_decouple= 'B111110' ;to decouple the eternal axis
    $axis_act.e1=0
    WAIT FOR $AXIS_JUS.E3==TRUE
    $async_axis='B000001' ; to couple it again


    But it does not work. Gives an error message
    Tell me please, how can I do this?

  • AD
  • KUKA, KR C v8.3.39, KS V8.3.483


    I changed the code. Now he is:
    DEF RESET_E2()
    ptp $pos_act
    $ASYNC_AXIS='B00010'
    WAIT SEC 0.5
    $ASYNC_EX_AX_DECOUPLE='B00010'
    WAIT SEC 0.5
    $AXIS_ACT.E2=0
    WAIT SEC 0.5
    $ASYNC_EX_AX_DECOUPLE='B00000'
    WAIT SEC 0.5
    $ASYNC_AXIS='B00000'
    END


    Gives an error message:


    Ackn. de-/coupling not allowed for axis E2


    stops at this line: $ASYNC_EX_AX_DECOUPLE='B00010'


  • Open your working project ib WoV, open drives configuration, right click on E1 motor and enable coupling, etc


    I did as you said. But I had another problem.
    I could not manually move the axis E2
    Look at 1st image.


    I also had to change the terminals from 1 and 2 to 7 and 8. Since when I switched on the coupling in WorkVisual, they changed from 1 and 2 to 7 and 8. Look at 2nd and 3rd image.


    When I go into the proposal proposal, WorkVisual wants to remove RDC. Look at video. :icon_wink:

  • topic started with assumption that all axes are configured and working, only one of the external axes needs position reset.
    suggestion was to enable coupling. that is all.
    but you did complete drives reconfiguration, and now wonder why things don't work... what is your point? i don't follow.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • [size=2]topic started with assumption that all axes are configured and working, only one of the external axes needs position reset.[/size]
    [size=2]suggestion was to enable coupling. that is all.[/size]
    [size=2]but you did complete drives reconfiguration, and now wonder why things don't work... what is your point? i don't follow.[/size]



    After all, I wrote, and even shot a video. When I include the coupling in WorkVisual, the contacts change from 1 and 2 to 7 and 8. If I set the project as it is, then nothing works. Therefore, I had to switch contacts to RDC from 1 and 2 to 7 and 8

  • Hi, i am looking for a solution to this topic.

    My Goal: After finishing the code i want to reset the value of the Extern Axis, without rotating all the way back.


    Open your working project ib WoV, open drives configuration, right click on E1 motor and enable coupling, etc

    I followed your advice and enabled coupling correctly.

    When i run the code following happens:


    //The Axis is finished with the program, the E2 value is 60, and before it goes back to home position, where the E2 value is 0 we want to reset without rotating.


    DEF RESET_E2()

    ptp $pos_act

    $ASYNC_AXIS='B00010'

    WAIT SEC 0.5

    $ASYNC_EX_AX_DECOUPLE='B00010'

    WAIT SEC 0.5 // Until here everything is fine lets say the axis has the value 60

    $AXIS_ACT.E2=0 // Here i expect the value to change back to 0 without rotating but the value does not change.

    WAIT SEC 0.5

    $ASYNC_EX_AX_DECOUPLE='B00000' // Here the the value changes to 0 and the unwanted rotation happens.

    WAIT SEC 0.5

    $ASYNC_AXIS='B00000'

    END

    I really want to find a solid solution to this problem.

    Thank you!

  • don't know what you have there....

    if $ASNC_OPT is FALSE, you cannot programmatically switch axis async. this is in $OPTION.DAT in controller MADA

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now