Tool keep missing fine object when picking it up

  • I was recently tasked to work on an older model of a fanuc robot arm which I didn't have any clue or foundation to stand upon.


    Our work cell has three feeders that will supply assembly material for the arm to pick up and place within the main assembly item. So far feeder 1 & 2 works fine but feeder 3 keeps giving us issues. Within feeder 3 we have small contacts (sockets) that the Tool keeps missing upon coming down to picking them up. However, if we orient the socket contact within the same orientation as the image it uses to recognize it, the arm is able to recognize which end to pick it up from, otherwise it will miss or aim right for the middle of the contact.


    So far we have tried numerous calibrations to try and solve the issue:
    1) TCP re-calibration, all the tools used have the same dimension and we did the test to move it around a center point and it worked fine.
    2) Re-calibrating the feeder user frame
    3) Re-imaging the socket contact


    Can someone provide another solution or method that hasn't been listed yet?


    :help:

    Edited once, last by Teddy ().

  • Place your Ad here!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners