Kuka iiwa, Sunnrice Cabinet, Ethercat WAGO 750-354, WorkVisual export error

  • Hello,


    by having a look on all the documentations kuka published I did not find any information, how to integrate a ethercat- PLC (in my case the WAGO https://www.wago.com/de/io-sys…thercat/p/750-354_000-001)
    My confusion starts in the bus-topology in WorkVisual. Is it right to connect the device to the port X65? In WorkVisual I do not see this port. Just X42, X44, X48.
    So which one is the right? And hwo to go on to integrate the WAGO module. I have the .xml description of the PLC, but how to integrate that into WorkVisual?
    I am looking forward to any kind of help.


    :merci:

  • Place your Ad here!
  • [size=2]the best way to get correct answer is to follow guidelines (see READ FIRST). that includes being specific, posting in right forum section etc. [/size]


    [size=2]failing to mention KSS or Sunrise version, WoV version etc is an example of not being specific. same goes with vague statements like 'having look on all the documentation'. you need to be specific, do not make us guess. [/size]


    [size=2]if you are planning to wire something to robot controller, the very first document you need to look at is - schematics. this is supplied with each system. if you check schematics for X65, you will see that this is just a cabinet interface (and those may have different labels depending on configuration). but if you read description and follow where it connects, there will likely be no more confusion.[/size]


    [size=2]in general there are several busses on KRC4:[/size]
    [size=2]KCB (Kuka Control Bus) - connects drivs etc. [/size]
    [size=2]KSB (Kuka System Bus)[/size]
    [size=2]KEB (Kuka Extension Bus)[/size]
    [size=2]KLI (Kuka Line Interface)[/size]



    [size=2]KCB and KSB are Kuka busses and users should stay away from those.[/size]
    [size=2]KEB and KLI are User networks[/size]



    [size=2]X42 is interface to connect smartPad.[/size]
    [size=2]X44 is Extension Bus. This is bus to add user I/Os[/size]
    [size=2]X48 is System Bus. [/size]



    [size=2]next issue is terminology - make sure to use correct one. your Wago device is not a PLC. it is a bus coupler.[/size]


    [size=2]KEB is meant as a low cost (free) interface for user to add I/O. if you want full featured fieldbus, you will need to dig deeper into the pockets ($$). with anything free there are some limitations (only master, no coupling, limited list of supported devices etc.).[/size]


    [size=2]i am not sure if your Wago device is supported or not - never used it myself. KUKA uses EtherCat I/O from Beckhoff and bus coupler that is definitely supported is EK1100. [/size]

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • thank you panic mode for this answere. you are right, that my explanation was not to detailed. The missing information you'll find in the the attachment.


    By downloading the *.xml from WAGO it was possible to add the device to WorkVisual and to connect the inputs.
    I get a connection via WorkVisual to the device.
    At the moment i am strugglingwith the exporting: https://www.robot-forum.com/ro…rror/msg131523/#msg131523

  • then why don't you provide all info required per instructions? i pointed you to a READ FIRST, then explicitly stated what you need to share and you still fail to do so (still no idea what is the exact Sunrise version you have there).




    issue is that you are using wrong version of WorkVisual. you should be using one that was delivered with the robot. i cannot tell you what version is needed without knowing your Sunrise OS version.





    why do you make multiple topics about same issue? this is spam
    why do you continue to post in wrong forum? this is spam



    guess what happens with spammers...

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • My Sunrise.OS is 1.14.1.15


    The Robot was delivered with KUKA.WorkVisual Version 5.0.2. Because I had problems to get that Version run on my computer, the Kuka-support recommended to go for the 5.0.7_Build0755. The Version of Sunrise Workbench is 1.14.1.15. You think there is a problem with version compatibilities?



    To detect the error source in the process of exporting the I/O-Configuration, i created a fresh project in the workbench. Opening the *.wvs in this project and exporting the I/O-Configurations leads to the same problem. (see attachment)




    Because i think integrating the WAGO module and the export problem are two different topics i separated them into two posts. So spamming was not my intention.

  • Yes, issue is with compatibility. When working with Sunrise OS, specific version of WorkVisual is required. In your case thT specific version is 5.0.2.313

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Thanks! :merci:


    So with right version of WorkVisual it is now possible to create the export without the error.
    After creating a new I/O-group (just two bool outputs) and linking them to two outputs of the WAGO-Ethercat system, a corresponding Java-Class was generated in the Sunrise Workbench.


    After uploading the the project to the controller a fieldbus error occurred. see attachment.
    - Error during Stack initialization
    - Slave-Init-Cmd: check device state for SAF
    - AL-Err: Invalid sync manager configuration


    The both errors are coming up frequently every 3 seconds, one after the other. And the whole fieldbus shows a red lamp (error).
    Could this be a not supporting of the hardware are any kind of wrong configuration.


    The WAGO-module shows on the error LED an error, too.

  • more details are needed:



    are you sure all wiring is correct? (are you really connecting to X44 port? is the power applied correctly? is the order of IO cards correct? do they all get power?)



    what are the settings you use? (is there any configuration required on the bus coupler? if so is it correct? did you map IOs?)

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

    Edited once, last by panic mode ().

  • The powering of the module should be fine.


    In the attachments i put a *.zip with the WAGO xml and the ioConfiguration.wvs


    I connected to x44 port. So via WorkVisual i get the diveice through remote connection do read diagnostic and the topologie.
    The automatic read out topologie is correct.


    I mapped the 4 digital outputs (only one card a 4do is connected to the coupler, to keep it simple) to a new groupe in "Sunrise I/Os"
    The Java-Class us generated in Sunrise Workbench and the groupe is shown on the Control-Panel of the Robot in the I/O-Groups, but shows up the explained error with a red signal light.

  • Hi,


    I have a follow up question on this thread: From your attached photos I see that you have chosen a KRC4 controller, but is this correct when using a Sunrise Cabinet controller?


    I am also working with a Sunrise Cabinet and i have installed the Sunrise Option Package to WorkVisual 5.0.10. When I try to open the IOConfiguration.wvs file from my project from Workbench in WorkVisual, a window with the header "Open catalog KukaRobots" opens. Which file should be chosen here? If I for instance choose to open "KukaControllers" , the controller in Project Structure view -> Hardware view -> controller1 is of the type KRC4, which is not correct.


    regards,

    Charlotte

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners