TAST troubleshooting

  • New to the forum, new to Fanuc. I'm fairly versed with Panasonic robots, but expanding to some ABB's and Fanucs that my company uses. I'm having some issues with a part that we are attempting to weld with one of our systems. I've gained a lot of information from this site, but never posted, so figured now is the time.

    We are using two 120ic robots to weld a very large, round part, with coordinated motion. We are welding two separate(but identical) parts at the same time. We are using root pass memorization as we are putting six passes on these parts. 2 inch material. R30iA controller.

    The issue i'm having is that when we start welding, it looks very nice. as it works its way around the entire part, it seems like the seam tracking is driving it up and out of the joint. Is there a setting within the tracking schedule that is maybe wrong that would cause this to happen?

    Thanks in advance for any help, if i'm lacking information needed, please let me know.

  • Do you use feedback or constant in your TAST schedule?
    Do you change weld parameters during weld?
    How long is OK section at the beginning?

    It is possible that you gain setting is two low.

    We are using constant in the TAST schedule, we do not change parameters during the weld. The weld looks good for approx 7", and i would say to weld all the way around it is somewhere around 30". L Gain is currently set at 33, i'm checking on the other.

  • update -

    So me being new to fanuc, i just started playing with settings. Ok i'll be totally honest, somebody else is playing with the settings, I'm just telling them which ones to play with haha. I adjusted the V and L dead band settings, to try to keep it from moving out if the seam only moved up to 3mm in either direction. After all, we are putting a one inch weld on this part, right? So far, that seemed to have solved my issues. Is there any disadvantage to using this setting the way I used it?

  • Dead band parameter tells robot to ignore required TAST offsets if offset is smaller than set value.
    This means that if dead band is 1 mm robot will correct the path only when required TAST offset is bigger than 1 mm.
    Is this what you want to achieve?

    Can you post your current TAST settings for problematic schedule?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now