KRC4 communication fault

  • Hello,


    I am reaching out to the community here to help troubleshoot a problem with the KRC4 controller for a KR6 R900
    We recently restored our controller to factory defaults using the Kuka Recovery 3.0 USB because of a fatal error. We since have lost connection between the controller and the robot. Diagnosis of the controller in WorkVisual shows errors for these modules (see attached). Additionally getting errors from HMI attached as well. I am attempting to solve this issue but I am totally new to controller and robot communications, so any advice would be much appreciated.


    Thank you,



    Zain

  • AD
  • Hi Panic Mode,


    We received our image from an ftp server provided by Kuka, downloaded the two wim files C and D to our Recovery USB, I think it should be correct. To provide more detail maybe helpful, the fatal error involved external communication from controller to another device, at that point, communication failed between the Kuka and controller and recovering to factory settings has not solved the issue.


    thanks,


    zk7

  • default image uses large robot with KRC4 standard. unless someone put effort to tailor that image specifically for your robot, this will NOT work out of box. You still need to create correct WoV project, deploy and activate it...

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hi Panic Mode,


    OK, thank you I was totally unaware of that. I will refer to the work visual manual for setup and post back if I run into problems. But just to be sure that I am just missing a configuration, do you have any documentation to recommend that would help me locate or diagnose problems in the hardware (ie if there is a series of leds not lighting up inside the cabinet or something). Please let me know, much appreciated,



    zk7

  • [size=2]modifying workvisual project is easy but creating one from scratch is more involved and should be done by Kuka.
    do you have archive or krcdiag or any sort of backup for your robot? what exact kind of KRC4 controller and what configuration?[/size]
    [size=2]basic project can be created based on serial numbers of robot and controller...[/size]

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

    Edited once, last by panic mode ().

  • Hi panic mode,


    We have a previous Work Visual project that I tried deploying but with no success, attached is the work visual error I received, I . I have been referring to it in modifying the factory default project currently on the controller, but even as I go through and add components to the Bus Structure, I cannot scan topologies and have them add automatically ( I am currently loading the project on the controller through ethernet).


    The controller is KRC4 compact 8.2.3. I include an image of the label on the controller as well.


    Thanks,


    zk7

  • your controller is from 2012 so it was delivered with early KSS (before BoardPackage), that was created specifically for small robots (KSS SR 8.2.3 is not the same as KSS 8.2.3, more like KSS 8.2.20). Configuration was done with WoV 2.4 and waggon driver, STEU etc were all picked or created manually.



    You may want to contact Kuka on this one. Once you get it working, use your recovery stick to create a backup image.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now