• Needs some help.. i have an R30iB Mate w\M10iA\12
    I'm getting srvo157 chgal = Cause: The charge of the capacitor of DC link voltage on the servo amplifier could not finish within
    specified time.

    i have tried everything the crc is saying and fanuc has said to try, changing amp, estop board and also tried the contact behind e stop board...
    i also verified that all voltages are correct...

    Has anyone seen this.. PLEASE HELP!!!!!

  • Check to see if you have dropped 1 leg of your 3-phase input power.
    Also make sure that connector CRRA12, at the bottom of the 6-channel servoamp, is connected properly.
    Also check that breaker QF2 is ON and not in the trip-free position. If it is trip-free, go all the way to OFF and then back to ON.

  • Also check CNMC6 at the E-Stop board. Pins 1, 2, & 3 supply the 200V to the E-Stop Unit and 4, 5, & 6 provide the precharge for the servo amp capacitors.
    Carefully look at all the connectors at the E-Stop and Servo Amp and make sure contacts are fully seated in their connectors and not discolored from heat.
    Very, very carefully use a low impedance meter to measure/verify the voltage coming from breaker QF2 as mentioned by USURP_RUR. Should be 200-240VAC with all voltages nearly equal when measured phase-to-phase. If it checks good, do the same at CRR38A on the servo amp while someone enables the deadman on the pendant.
    When changing out the E-Stop & Servo Amp, were all the jumpers moved to the new units?
    Also when changing unit, a cable may get missed if it ends up behind something else, I missed plugging a brake connector back in last week.

  • I just had the same issue today. SRVO-157 CHGAL Gr1 axis 1 and 2 on an M20ia 12L robot. Checked the voltage at all the connectors as the manual suggested. Everything checked out okay. Replaced the servo amplifier, fortunately we have quite a few of these robot controllers in the facility so we swapped it out with a known good amplifier and still a no go. Swapped out the e-stop board and replaced the contactors behind it. We were able to get the robot to reset and move around in teach. Oddly though we didnt have to master the robot?!?! It ran in auto for about two seconds before shutting down for the same fault. We ended up calling a Fanuc Tech in to help troubleshoot the issue. The quote included new servo cabling for the robot. When I asked why they quoted that they said from past experience the cabling often needs replaced. They also quoted a new breaker and replacement servo motor in case one the axis needs it replaced. None of this was in the manual so I hope this helps anyone with the same issue. There are a few more options to try if following the manual doesn't offer a solution.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now