I/O Communication problem wiith PLC

  • The internal IO you are referring to is the 1KP relay outputs and the 1KB/1RB inputs I've been referring to.

    That's what I understood and saw ... but do they use the same addresses (eg 1,2,3, ..., 32 and 1001, 1002, ..., 1032) for both boards? For example, if I want to use output 9 of the 1HW board with the "signal 9" command, how do I know where to execute it? I'm waiting for a signal on 1HW and it activates my output on 1KP .... I say this in the context in which I ran the FOR loop ... if I use the OPENI / CLOSEI commands it's something else, I expect it to activate my output on the 1KP board. ..I'm wrong somewhere?


    Do you suggest me to disable the built-in IO from Aux 0610?

  • Place your Ad here!
  • If you read my previous reply, I mention this regarding Arm IO and 1HW IO.


    Historically this is what CN3 was purposed for, as prior to D Controller was C Controller which used the same IO board.

    But C Controller never had the 1KP or 1KB/!RB boards, so they had a physical harness attached to CN3 instead.

    This is why I said, don't worry about CN3.


    When D Controller came out, CN3 became redundant as 1KP and 1KB/!RB provide the signals instead.


    But they still did not differentiate between Arm IO and 1HW IO until the release of Arm ID board (which is not fitted in FD50 Arms).


    Try and disable it in Aux 0610 and see what happens.

  • In the Operation Manual.

    It does not cover every single detail, but contains enough information (in true Kawasaki fashion).


    If you re-read post #53, you will see I mention disabling these inputs and outputs via the jumpers on 1HW to prevent common sharing between 1KP/1KB/1RB and 1GW/1HW.

  • Back in the day with D Controller an integrator would either use the Arm IO in conjunction with 1HW IO or just use 1HW IO instead.

    Therefore, if they did use the Arm IO and the 1HW IO they were supposed to change the jumpers on the 1HW, disabling the Arm IO from being available on CN2 and CN4.


    The fieldbus information is contained within the backup, but thinking about it, I think the information I see is default information as standard.

    But the fieldbus is not enabled, so any configuration here is never used until fieldbus is enabled.

    Just do a search for FIBUS in the backup, the information is there if you can decipher it.

    Did it use fieldbus in it's previous usage - Interbus do you know?

  • The fieldbus settings maybe default then.....I can't remember that far back D Controllers are a good 15 years old.

    2. If 1GW/1HW board Standard Jumpers:

    - Check J1 Jumper for correct address setting in line with total IO set in Aux 0611. (each IO board contains 32 inputs, 32 outputs).

    - Check J2 jumpers are correct (B-C Setting OFF), any jumpers left in A-B setting will disable the outputs.

    - Check jumper J3 and J4 are correct (B-C setting), this will allow outputs 9-16 to be available on CN2.

    - Check jumper J5 is correct (A-B setting), this will allow inputs 13-16 to be available on CN4.

    J3, J4 and J5 as stated in the post.

    It also has this printed on the board next to the jumpers on the 1HW board too.


    Try what I have sent you in the conversation in your account here at robot forum and see if that works.

  • Hi,


    I finally solved the problem ... thanks to kwakisaki's suggestions everything works OK now...


    How did I solve it? I modified some specific configuration options from robot file configuration and I disabled Aux 0610.




    Many thanks Kwakisaki!


    Continue like this, congratulations for the volunteer work you do, helping with advice, suggestions, documentation to all members of this forum who asked for support to solve various issues related to the operation of robots.


    Best regards!

  • Excellent news........and many thanks for your comments, it's very much appreciated indeed.


    Your patience and perseverance throughout this is most commendable, a lot of users would result to a complete wipe and re-configure in the hope of rectifying problems which often removes the problem, but does not provide information of what the problem was.

    So by the information you've provided and also the 'long hours' you've spent going over wiring etc, you've managed to get to the underlying issue.


    So just to update anyone reading this thread:

    When using KLOGIC, it removes the standard AS IO addressing for the installed 1GW/1HW and re-addresses the 1GW/1HW IO in line with KLOGIC addressing.

    This is stipulated in the KLOGIC Manual, section 2.3


    Your information and feedback will hopefully provide any visitors valuable information should they experience a similar issue and that's is the purpose of the forum to share globally, knowledge and previous experiences.


    dovdor a job well done my friend.......:beerchug:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners