I/O Communication problem wiith PLC

  • Disconnect just the solenoid island when testing the 1HW's again (leave the main umbilicals attached, so you wont have the other errors).

    I will do the tests only with the plugs of the harness cables inserted, because in the previous test there was an error regarding the encoder (E1030) and the robot was working incorrectly.

  • Place your Ad here!
  • Those settings are not the same from the filesave you posted.........


    Were these settings from when it was working?


    Yes, do the testing that way and see what the results are.


    FYI

    Disconnecting and reconnecting the umbilicals will not cause any issues, unless your encoder batteries are low.

    You just wont be able to move the robot whilst disconnected.

    If some encoder values do change, then upon reconnection the values will then be different than the stored ones, thus abnormality errors occur.

    This is just an indication that the encoder values have changed and not necessarily a problem.

    Just by resetting the error is normally suffice to clear and carry on.

    So testing is available without umbilicals without introducing issues, I do it all the time.

  • You have right, the filesave was made a few days ago while the changes in Aux 0605 was made today ... hence the differences ...

    Question: when I activate the Clamp function with A + CL1 shouldn't I hear the relay on the KP board working?

  • The file save you posted is not from the controller directly, it has been modified offline.


    You would be better to just have two clamps set up for testing:

    - Clamp 1 at 9 ON and 10 OFF.

    - Clamp 2 at 11 ON and 12 OFF.

    - Set the the remaining clamps to 24 ON and 0 OFF (these are the defaults).


    Regarding hearing the relays, no idea, I don't test relays by listening to them.

    Armatures can switch (this is the noise you hear) and contacts can still be welded - giving incorrect results.

    Always better probing relay outputs and not rely on the 'noise'.

    You can pick up by accessing the internal harness connectors in the robot and measuring them reference 5-27 of the TS Manual.

    - The connectors themselves are easy to access for DVM probes.

    - The outputs are on X116 inside the robot.

    - Inputs and the 24V and 24G references are on X124.


    Can you take a close up and clear image of the small black dipswitches located on the 1RB board in between the 2 rear backplane connectors?

    - Should be S4, S5, S6, S7 and S10.

  • Change Aux 0611 to 0 input and 0 output.

    - Power off.

    - add 1x 1Hw (set at 1-32) and power up.

    - Change Aux 0611 to 32 input and 32 output and power off.

    - Power up - No error should be displayed.

    Hi,


    I can tell you that for the moment I have solved the error problem (E1009) generated by the 1HW board following the instructions above. Now I have to connect some inputs and outputs on the board mentioned to see how it works.


    The problem of the builtin signal cables (I / O) has remained unresolved for the time being ... I will come back after doing some more checks ...


    Thank you very much kwakisaki! You have been a real help to me!


    Regards!

  • You're vey welcome.

    Thanks for reporting it back, that's good news in part getting the general purpose IO going.

    The order of configuration should not matter, so I'm surprised explicitly that procedure resolved it........software may have just got a little pickled in that case.

    But we'll take that.

    Nice job.......:top:


    If you clear the VME Bus errors and built in IO next, this will be a good one to resolve as it's a little bit of an oddball one.

  • Hi,


    I came back.. finally I managed to connect all the inputs and outputs necessary for my application, but I found that my 1HW board still doesn't work, although this time it doesn't give me any error ... It doesn't see any input signal and it doesn't order outputs ...


    Is there another setting or configuration (software or hardware) besides Aux0611 that I should do to activate this module?


    I measured the voltages on the active inputs and found that there is a voltage drop of approx. 2 Vdc ... finally with CN4 connected on the 1HW measuring board on the active inputs only +22.1 Vdc, which is not normal.


    on outputs, 0 Vdc ...


    I also ran a program for testing the inputs and outputs and I seem to have the impression that when it reaches the line signal 1,2, 3,...., n it jumps over it, without executing it ...


    Do you have any suggestions that might help me, what else should I check?


    Thanks in advance!

    Regards ..

  • As long as the controller has been set to 'look' for the 1HW by setting the total IO in blocks of 32 and the 1HW is addressed correctly, you will not receive any errors if they are both 'talking to each other'.

    You will not receive any errors if IO is not reading/sending.....unless controller and 1HW is not communicating with each other along the VME bus.


    Even though these are considered digital IO, you still need to remember the analogue aspect of the circuit - especially C and D Controller 1GW/1HW.

    Inputs:

    - Inputs are rated @ 10mA in order to operate the optocoupler.

    - Even at an input voltage of 21.6V to 26.4V the specs say it should operate.

    - The circuit design (optocoupler) will always incur a voltage drop across the optocoupler led possibly as much as 1.3V (forward voltage for current source).

    - This led drives the output transistor to the low level logic on the control side.

    - As long as this optocoupler is receiving 10mA of source current, then the output transistor should switch the transistor on the low level logic side.

    - So within these, it should operate - providing the optocoupler/input circuit is correct and is not damaged.

    - Now if your 'source' 24V to the board is dropping, then that is a different matter, as either the source cannot deliver the current, or there is a short circuit.


    Outputs:

    - Each output are rated @ 100mA of source current via an optocoupler isolated transistor array.

    - Internally this is just a transistor that is turned on of off by low level logic from the control side firing the optocoupler led.

    - Inductive loads will require suppression such as surge absorbers (freewheeling diodes for example).

    - Small signal relays are the preferred method as opposed to direct peripheral wiring for devices requiring >100mA.

    - Output voltage will depend on the load attached, otherwise voltage output maybe low or transistor is damaged in the transistor array (S/C or O/C).

    - Now if your 'source' 24V to the board is dropping, then that is a different matter, as either the source cannot deliver the current, or there is a short circuit.


    1. C and D Controller IO boards have 2 different flavours:

    - 1GW (US and Japanese Spec) - NPN Configuration.

    - 1HW (European Spec) - PNP Configuration

    - Use external IO manual to wire up according to correct flavour of board you have, failure may cause damage to the board or connected peripherals.


    2. If 1GW/1HW board Standard Jumpers:

    - Check J1 Jumper for correct address setting in line with total IO set in Aux 0611. (each IO board contains 32 inputs, 32 outputs).

    - Check J2 jumpers are correct (B-C Setting OFF), any jumpers left in A-B setting will disable the outputs.

    - Check jumper J3 and J4 are correct (B-C setting), this will allow outputs 9-16 to be available on CN2.

    - Check jumper J5 is correct (A-B setting), this will allow inputs 13-16 to be available on CN4.


    3. Check you are connecting to correct CNx connector:

    - CN2 is output connector (male).

    - CN4 is input connector (female).

    - CN3 may have cable - this is for arm signals, to disable these, check J3/J4/J5 Jumpers as outlined above.


    4. Check the wiring is correct to CN2 and CN4 relative to flavour of board.

    - IO pin numbers are not pin for pin for all inputs and outputs (CN2/CN4 pins 1-16 = IO 1-16), (CN2/CN4 pins 20-35 = IO 17-32).

    - CN2 pin 17 is N/C

    - CN4 pins 17, 36, 37 are N/C.

    - Check VIN1 and COM1 (for 1st 16 IO) and VIN2 and COM2 (for 2nd 16 IO) are connected correctly.

    - VIN1 and VIN2 can be tied together and COM1 and COM2 can be tied together if required.


    The above points are very often overlooked when new to Kawasaki and many assumptions are made, so please review and use external IO manual for correct wiring and configuration and confirm correct for type of board in use.


    5. What is being displayed on the IO monitor screen.

    - Do your inputs light up when inputting a signal - if it does, then the controller is seeing it.

    - Do you outputs light up when outputting a signal - if it does, then the controller is sending the logic to the 1GW/1HW board.


    6. Have you got dedicated signals allocated to the 1GW/1HW - Check 0601 and 0602.

    - If so, then these cannot be activated by commands, only functions.


    7. Provide a full backup including your test program so I can check for abnormalities.

  • Hi,


    First of all I want to thank you for the answer.

    Regarding to your suggestions for connectivity checks, I can tell you that I've done them a few times so far. In the following, I will try to answer punctually to each point in accordance with what you told me to check:

    1. my board is HW type, so it's PNP;

    2. jumpers J1, J2, J3, J4 and J5 are set exactly as you mentioned;

    3. the connection of the CN2 and CN4 connectors is in accordance with the IO manual, except CN3 where I don't have any cable and I don't even know where to connect it or how to set it from jumpers;

    4. the wire connections are made in accordance with the IO manual;

    5. I don't see any signal on the IO monitor, neither on inputs or on outputs ... maybe I don't look where I need to, you can be more specific ?;

    6. I will attach some pictures with the settings from Aux 0601 and 0602 as they are at the moment ... maybe here is the problem ...


    Thank you!

  • Aux 0603 is just the area to attach a 'name' to IO, which is just a label and has no bearing on functionality or not.


    IO Monitor screen as images:





    Light grey indicates OFF

    Yellow indicates ON

    Dark Grey indicates Dedicated Signal is OFF (if allocated).

    Orange indicates Dedicated Signal is ON (if allocated).


    You see the red box on the output side, use the cursors to move it around the output screen.

    Stop on an output and press A and 1 on the teach pendant to turn it on - it should turn yellow.

    To turn off, just press A and 2 and it will return to light grey.


    You cannot force inputs, they need to see the relative to voltage on the input pin to show it is on and no voltage on the relative pin would remain light grey.

    Have a look at this screen and let me know your results.

  • In Kawasaki AS Language:

    - Inputs are referenced as 1001 - 1032

    - Outputs are referenced as 1- 32

    - Internal Signals are referenced as 2001-2255


    I don't really see any program in your backup that you are using to test.

    You have unallocated all IO from any dedicated signals, so all IO should be available in code.


    Put the following in a PC Program and execute it and look at the output monitor screen outputs.


    FOR .tmp = 1 to 32

    SIGNAL .tmp

    TWAIT 1

    SIGNAL -.tmp

    TWAIT 1

    END


    Each output should turn on and off over 2 sec period and be displayed sequentially on the screen, the physical output if connected to a peripheral should operate to.

    As I don't know what is connected to CN2, you should remove it during the test so as not to inadvertently trigger external peripherals.


    To test the Inputs, do the same program again except this time change it to:

    FOR .tmp = 1001 to 1032

    SWAIT .tmp

    TWAIT 1

    SWAIT -.tmp

    TWAIT 1

    END


    The PC Program will wait to see input 1001, then wait to see it turn off, then move onto input 1002 etc.

    You will need physical switch on inputs to test to cycle through inputs.

    This would test your inputs are working.

  • Why do insist on providing a backup that has not come from the controller, you always seem to provide your offline file?

    Has any other backup ever been loaded up to the controller from a different one of different source?

    Are you using KLOGIC, as it appears in your backup, yet the LSQ program does not exist.....where is it?


    In future, please take backup directly from controller and post it.

  • Why do insist on providing a backup that has not come from the controller, you always seem to provide your offline file?

    Hi,


    Here it is a copy of the controller that was downloaded with KIDE ... this is identical with the offline file ..that's why I considered that the copy from the controller is not necessary ...


    In this file as well as in the one previously transmitted, there is also the test program "small()", in which I tried to test only the inputs and outputs that I physically allocated and which I intend to use in my application.


    I don't use KLOGIC, it was exists in the memory of the controller from the previous application where this robot was used ...


    I will try on Monday to load the routines suggested by you and I will come back with the result of this test.


    Thank you!


    Regards.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners