Plc with roboguide

  • I've talked to others who have successfully configured and connected Roboguide as an EIP scanner.

    Are there any background programs running on your PC that might be preventing the connection from going ONLINE? (Per my post above).

    I couldn't get my Roboguide Adapter connection ONLINE until I started closing out background programs in task manager, and it finally took.

  • Place your Ad here!
  • Thanks Nxt2010. I did try stopping some of the background programs and services. I'll give it another attempt though. Maybe I can create a virtual machine with a fresh install of Windows to eliminate the possibility of interference from another program or service.

    • Helpful

    I was able to connect to a Turck IO Block using Ethernet/IP with the Roboguide robot as the Scanner. I followed the instructions mentioned previously in this thread. But at first it still would not work. I could ping the IO Block from the Roboguide robot but the connection would remain OFFLINE.

    Finally I recorded some packets using Wireshark. One of the packets had "Connection Failure (0x01)" and "Extended Status" Revision mismatch (0x0116)". Those error codes are in the Fanuc Ethernet/IP manual. I set the Major Revision and Minor Revision to 0 in the Ethernet/IP connection settings on the Roboguide robot and it worked!

    The weird part is that I am almost positive that the values I was using for Major and Minor Revision worked when we connected the IO Block to a real robot. I can't test it right now, but we recorded all the settings we used when we previously had it connected to a real robot.

    I recommend using Wireshark to anyone trying to connect Roboguide to an Ethernet/IP device.

  • Hello all. I've been playing around with roboguide connected to a physical compact logic PLC via Ethernet/IP since back in 2018. Hugely helpful for developing complete applications at home.

    Our company just recently got access to FT Logix Echo and I've spent most of the day experimenting with getting an Echo controller on my laptop to talk to Roboguide on that same laptop.

    After sorting out many IP address issues... I think they're "seeing each other"... but I'm still getting the following error message.

    Has anyone successfully configured Logix Echo to Roboguide?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners