hand broken sinal

  • R30iB+ controller, Mig welders with no use of the hand broken feature(no clutches, shock sensors, etc.)...

    Hello All,

    -I have had an issue with the hand broken feature on at least 3 mig welding cells that I am integrating at this time out of numerous cells.
    -On two of the cells, they were dual arm and on the third cell, it had three arms.
    -I had been working on these cells for at least 3-4 weeks going through the integration phase, path programming, and weld validation with no issues.

    So my issue/concern is that one of the groups has its hand broken signal enabled without me physically changing it myself as I have no reason to. When this occurs, I cannot move my robot around due to the srvo-102 alarm. I can only clear the alarm when I go back into the CONFIG menu and disable it. I attempted to call Fanuc tech support and did not get much feedback other than them telling me that it is not possible that it can go from disabled to enabled without being switch by a person. The last time this issue occurred, the system was running as should be yesterday and I shut down the system at the end of the day. I started it back up this morning and the hand broken signal for one of the groups was enabled causing me issues.

    I have never had this issue before and this is the first time I worked with the 30iB+ controller. Could it be possible that something in a board or somewhere in the controller is triggering this signal or any other reason that the signal is being enabled without a person physically doing it? Any thoughts or comments would be appreciated!

  • I took a look at all programs and only found that two karel programs (named comset.vr) are using that variable and I couldn't tell you if that is what is causing it (doubt it though). So far to date, this issue has happened 6 times across 5 cells out of 15 cells that we are currently integrating. I have no experience with karel so I don't know what I can do with that. Also, it has only occurred immediately after startup and not during normal operations.

    Worse case I can run a BG program to continuously set that variable to 0 but that only band-aids the problem. Any other thoughts?

  • If it's a *.vr extension file you can convert it to *.va and open it in notepad.

    Do controlled start
    Go to file menu.
    Select MD as directory
    Copy all programs/selected program to UD1/UT1/MC (whatever you want)

    That way you can get your *.VA file and see what is going on / edit it.

  • Just had the same issue with my R30iB + controller.
    I used the workaround suggested by HawkME and it solved the problem.

    Does anyone know what triggers the Karel programs to set the HAND BROKEN parameter?

  • I have an update on this issue I'd like to share.

    The handbroken happened again in one of our machines while I was there, so I was able to properly debug the issue. It happened while I was configuring the machine and loading the backup.

    The BG logic program solved the problem but not the root cause.
    The issue persisted after cycling power.
    The issue solved itself by doing a few cycles of reset, deadman and jog movements.

    My best guess is it's an undocumented issue of the robot software that happens rarely when configurations are changed.

Advertising from our partners