• Greetings. :hi-bye:

    My name is Alberto, I'm from Spain and I'm 21. I'm a fellow at a company in my area. I have studied automation and industrial robotics at a local institute.

    Now, in my work, I have been put in charge of a Kuka Robot, supposedly a KR C1.

    In this post I will be writing my doubts and the process that I am carrying out.

    Thanks in advance to everyone who reads my post and to those who can help me with their knowledge.

  • AD
  • DAY 1 . 03/19/2018

    When turning on the Robot PC, it locks everything up and the following errors appear:

    // It must be mentioned that the robot with which I am working comes from an external company in which it had a seventh axis with which the entire robotic arm was moved from one side to the other.

    - SoftPLC: Application of Base RS: 30

    Compiling the information studied some time ago about the configuration of the axes, I am going to try to eliminate the errors of the E1.

    It does not work because the $ Machine file is the one that I have edited to try to solve the problem. When you finish editing it, you have already changed the parameters of the seventh axis and decide to restart the PC to check if the error is going, the file $ Machine is restored to how it was from the beginning.

  • First, you appear to have a connection failure to E1. Does this robot even have an E1 axis?

    Second, the Mastering messages for all axes suggest that, at minimum, your batteries are dead and require replacement.

    What is this robot's history? Is it a second-hand robot that was recently purchased? Or has it been in use in this facility more recently? Is this a "stock" KRC, or a customized version (VW, Audi, GM, etc)?

  • Hello, SkyeFire.

    1. The robot currently has no axis E1. But in the programming if I tried to delete its configuration but I have not known how to do it.

    2. I will check the batteries as soon as possible.

    3. This robot was bought from a company. Therefore it is second hand. He has been around for 1 year without being used. And theoretically if it is an "original" KRC

  • Thank you very much SkyeFire. What you said has worked and the errors of the E1 axis no longer appear. There is less left to make it work. The errors that I have left to solve are the following:

    - Perform A1 axis adjustment
    - Perform axis A2 adjustment
    - Perform A3 axle adjustment
    - Perform A4 axis adjustment
    - Perform A5 axis adjustment
    - Perform axis adjustment A6
    - Emergency stop
    - Non-prepared acyaminetic preparations
    - SoftPLC: Application of Base R3.30

    I understand that before I can calibrate the axes of the robot I have to solve the issue of emergency stoppage, prepare the drives and the theme of the SoftPLC

  • For the E-Stop, you need to determine what safety interface your KRC has, and what (if anything) is wired into it.

    I don't know what the "non-prepared" error is -- post the actual error code number.

    The SoftPLC is something custom that was added to that controller in the past. Without specific detailed knowledge of its configuration, I can't help with it.

  • Hi, Currently the robot is located in the middle of the workshop. It does not have a security fence as such. I guess I should simulate it somehow, right?

    In none of the errors mentioned above does a code appear. I have had other errors in that same robot that already solve that if they had code, but these do not have.

    The SoftPLC for what you tell me, is one thing that if I find, I could eliminate without any fear, right?

  • ...what? If the error message appears without a code, then it's not a KUKA system error. It almost has to be sourcing from one of the custom software items (possibly the SoftPLC) in the robot. I was assuming that the "perform adjustment Axis xxx" error messages were badly translated Mastering Required messages.

    This... changes quite a bit. Unfortunately, simply eliminating the SoftPLC does not remove anything in the Level 0 or Level 1 interpreters that may depend on the SoftPLC. There's no simple way to address this, short of perhaps doing a complete ground-up clean install of a stock version of KSS. But if this KRC also has customized hardware (like the VW-specific models), then there are issues simply installing "stock" KSS.

  • Ups, I'm sorry. The errors have code. I apologize for not realizing. I would be tired and I didn't see them.

    The codes are the following:

    14. SOFTPLC: @P1@

  • I believe that the error of the emergency button is because some hardware fails. Theoretically the security system will have to be connected in "X11" but in my case there is nothing. The security for what I have seen and have come to understand, is being sent to the top of the computer case. That upper part is where the seventh axis and the welding system that I previously had was theoretically connected. The upper part has a security relay (PILZ pnoz 11) and that's what I can understand that security is there but at that point it's where I get lost.

  • Well, that simplifies things a bit. You definitely need to re-master all the axes, and your E-Stop error is definitely coming from your X11 interface (assuming this is a standard KRC1, and has not had any hardware customizations).

    Do you have the internal wiring schematics for the controller? It should have them inside the cabinet, but I've noticed that many second-hand robots tend to have lost them. If not, I believe the Manuals sub-forum has wiring diagrams for the standard X11 interface. You will need a compatible Harting connector and pins to build an interface from. The X11 interface is designed entirely around "dry" contacts for relays -- you can substitute a simple jumper wire to bypass a particular safety circuit. However, keep in mind that any bypassed safety represents a serious potential safety risk.

  • [size=2]maybe...

    for e-stop message i would check drawings. are you sure that safety interface is wired correctly and operational? what is the safety interface? (depends on version of controller).

    messages about mastering are telling that robot needs to be mastered. i would fist check if there is communication with RDC and if mastering loss coincides with powering down.[/size]

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • If I am currently checking the security wiring and I am finding some basics of where the error may come from. Many thanks for the help. I will be informed of my progress.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now