Advertising

MRC Welding Issue

  • Hi,


    I'm working on an MRC control with a K6 arm, Hobart HUWI interface and Hobart Arc Master 351 power supply. This system was in storage for a few years and I have been asked to help get it up and running.


    We have most things up and running and are doing some test welds but seem to not have control of the wire speed. I have set up the welder condition file per an old Hobart document I found.


    When I use the wire retract/feed buttons on the pendant thing work and the speed changes with the High Spd button depressed.


    If I turn output 127 on and set a wire speed with the Arccur command in a program I can make the wire speed respond to command.


    When I use an arcstart condition file in a weld job, the travel speed and arc voltage are fine, but the wire speed is slow and does not respond to command changes. I have verified that the MEW board is sending an analog signal to the Hobart interface and it changes proportionally to the command in the arc start file.


    There are some diagnostic LED's on the Hobart interface and they show that the wire feeder is in "Inch" mode when running from the arc start file and in "Run" mode when driven by turning on output 127. This corresponds with the results I am seeing.


    Does anyone have any thoughts on this?


    Thanks,


    Ron

  • AD
  • Hi , I’m not familular with your welder setup, however, some “welders “ when Arc On is requested start with a slow wire speed and increase when an “Arc is struck” to requested higher Arc file condition wire speed.
    This is used to get a better Arc start . With teach pendant it can operate as you describe .

  • Hi,


    This system can be set up with independent start/run voltage and wire speed or just a single voltage and wire speed setting attached to as arc start file. I have tried both methods with the same result. The weld is established and makes a weld, but we cannot get the wire speed to respond to command and it feeds at a very low rate. We can change the rate by turning the wire feed output (OT 127) on and setting the analog output with the arccur command.


    It seems that when we use an arcstart command that the feeder gets an inch command from the MEW02 board.


    I'm trying to dig up information on the HUWI interface to see how it interacts with the MEW02, but given the systems age that seems to be a challenge.


    Thanks,


    Ron

  • Without knowing the history of the robot, it makes the situation complicated. But I would start by checking that the proper welding condition file is loaded with the right tables for analog - current and analog - voltage. If everything looks correct, check to see if the file is in IPM or Amps. Everything might be lower is the scaling is in amperage, not wire feed speed - depending on where you got the robot from.


    You will have difficulty getting information about the HUWI. Most customers with the HUWI or even UWI have now upgraded their welder to Miller or equivalent. Best of luck!

  • I do have a Hobart manual for the HUWI that describes the setup and I believe it is correct as far as the analog setup. The issue seems to be in the digital part of the interface as it inches when welding instead of running. Do you know if the outputs from the MEW02 board stay consistent with different welder setups? Just wondering of a wire feed command from the MEW02 comes out on the same pin and wired to the appropriate inout on the welder interface.


    Thanks,


    Ron

  • Try a line instruction ARCON using A and V setting. This is a raw request for analog values.
    the values for the A and V welds will be -14 to +14
    If your weld feed changes with a change of the AWELD setting, you might be missing the scaling data for the welder or the wrong welder selected


    I don't have a Motoman in front of me right now, but the code will look something like


    ARCON AWELD 10 VWELD 10

    Oh, well

    Edited once, last by tony gast ().

  • Tony has the right idea. You will need to press EDIT, then DEVICE (F3) to access these commands. They are 3 separate commands. I would suggest putting them in this order:


    ARCON
    AWELD 10
    VWELD 10


    where AWELD is analog amperage and VWELD is analog voltage.


    Sorry Tony, I didn't mean to correct you - but I still get a lot of requests for MRC support and training up here in Canada, so I probably do it a little more often. My apologies. :merci:

  • I have not touched a MRC in over 10 years..... LOL I was trying to remember, but us OLD guys have a lot of memory issues.....
    I just remember a similar issue back in the early 2000s ...... I do not feel corrected, but re-informed :beerchug:

    Oh, well

  • Sorry to dig this up but it's interesting to me[emoji6]
    Splinky did this work for you?


    Hello old guys![emoji4]
    At our plant we received a few motomans (nx100 and xrc)from another plant who use that type of command the arcon and a and v weld command. (Not in the same order but that doesn't matter i guess)
    So if i understand correctly the AWELD command sets the amperage and the VWELD sets the wirespeed (in my case it does)
    It's the values that i don't understand...what do they stand for the -14 to 14?
    Thanks for reading me! [emoji4]

  • Robogirl,


    The analog card in a Yaskawa robot can put out a voltage from -14 to +14 volts. Most welders use a voltage reference from 0 to +10 volts so you need to build a truth table. Set the Vweld to 2 volts and see what voltage you get out of the welder, then do the same thing at 4 volts and 6 volts and 8 volts... In the NX you can put these values in the welder definition and then use the in line command to set the voltage you want (the robot does the math backwards to set the correct analog voltage for the value you put in). You need to do the same thing for the Aweld. This is more difficult because you will feed wire and the robot will be looking for the "arc established" signal. If you remove the welder positive cable and fake the arc established signal you can feed wire for a set time (10 seconds), measure the wire and multiply by 6 to get inches per minute.

    Robodoc

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now