Using KUKA OFFICE LITE V8.2 with DELMIA V5 with RRSII connection

  • Hi ALL :hi-bye:
    i'm new here.
    Can someone explain me if it is possibile to connect kuka office lite v8.2 (running in vmware virtual machine) with delmia V56R2017 by RRSII connection ?


    I tried but delmia documentation is not cleare.
    I have delmia V56R2017 with RRSII option and kuka office lite V8.2
    I'm using kuka simpro 2 for 3d kuka robot simulation but I want to try the connection with delmia.
    Maybe needs a further license by kuka ?


    Thank you

  • Place your Ad here!
  • I am guessing you have already done it but, in general, you must select the “Sim Pro 2.0” option when you are installing Kuka OL to get the RRS-II components (Kuka VRC Manager/Instance applications) installed on the Kuka OL/VRC machine.


    Then, you need to do the following (assuming you are running on 64-bit V5 on Win 7+ machine):
    • Copy oncrpc.dll and pm_ascii.exe (ONC RPC portmapper application) into their V5 machine’s C:\Windows folder (attached).
    • Edit V5 installations win_b64\startup\rrs\rrs.servers file, duplicate the KUKA_VRC_Manager5 line, rename it to say KUKA_VRC_Manager6 (can be anything that is different than what is already there), and change “localhost” to the name (or IP address) of the Kuka 8.2 OL/VRC machine, and save the updated rrs.servers file,
    • On the Kuka 8.2 OL/VRC machine, run the Kuka VRC Manager application (there should be shortcut on the desktop)
    • On the V5 machine:
    o Run pm_ascii.exe and keep it running
    o RRS connect the V5 robot selecting:
     RRS Server=KUKA_VRC_Manager6 (<Kuka 8.2 OL/VRC machine>:300748)
     Controller Config=<the appropriate manipulator type from the dropdown that will show all robots under C:\KUKA\ALMADA on the Kuka 8.2 OL/VRC machine


    That should do it.

  • Thank you so much MR. Roboto,
    can you explain me how to open the attached ONC RPC portmapper application ?
    I tried to rename as zip,msi,exe without success... From the download I see a .doc file
    Thank you again :hi-bye:

  • Sorry Mr. Roboto, I found an pm_ascii.exe on internet :top:


    I copied the files in windos, started pm_ascii, renamed the rss server file and I can connect.


    I select the robot, start RSSII connection, the smartpad start on virtual machine and show me the choice of the robot type.


    But at the end of the process I get this message and I can't see the robot move syncronized with the smartpad....
    Could you help me ?


    Attached the images witt the messages from delmia

  • hello everyone:


    "I want to configure Delmia's RRS, but I don't have the relevant configuration file for RRS. Can someone kind enough share it?"?


    Thank you. :smiling_face:

  • hello everyone:


    Where can I obtain the Kuka KRC 1. XX to 5. XX RRS files? I have been searching for them for a long time but haven't found them. Can you share them?


    Thank you. :smiling_face:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners