Fully discharged RAM battery caused NO ability for motor power ON

  • Good day! :help: REALLY need help!


    Problem: don’t working «Motor power ON» after dead RAM battery replacement at FS003NFD70 robot.


    History of the problem:
    Fully discharged backup battery (on 1KA board, 0.15V measurement instead of 3.6V normally) corsed red «Kawasaki» logo hanging on white screen at Teach Pendant (the robot was not used at the summertime).


    Applied treatment course:
    – RAM lithium battery was replaced (coursed the same starting window with «Kawasaki» logo at Teach Pendant)


    – «Initialization window/0 NO» was choosen (using switch 8 of 1KA board to ON). (Resulted in: AC primary power off [System data sum check error => Set initial value]
    (D2023)Failed to load arm data


    – «Initializaition window/1. Initialization of the system» was choosed
    (D1017)Download error of servo data
    (D1016)The servo data file does not include available servo data
    (E0903)Check sum error of system data


    – Backup .as file was loaded (via notebook TCP/IP communication, the backup file was saved several months ago from just that robot).
    While loading several dialogs with (Strongly recommended… skip/force – force choise was choosen). That coursed following errors:
    (D1507)AC primary power off
    (E0903)Check sum error of system data
    (E1030)Encoder data is abnormal



    All errors have been reset (Check sum error by CHSUM AS command), but NO «Motor power ON» is since available!


    – CPU error occurred while AS command «save r2E0809.el»:
    >save r2E0809.el
    Saving… (r2E0809.el)
    Network configuration data
    ROBOT DATA
    OPERATION INFORMATION DATA
    SYSTEM DATA
    AUX DATA
    (D0001)CPU error.(PC=37EA7BF6)


    (D0001)CPU error.(PC=A639DE3B)


    After reloading the controller the file was normally saved by the command:
    >save/elog r2E0809


    Other functionality (DIO signals, Teach Pendant functionality and so on are just fine, but no ability for the MOTOR POWER ON)


    More about the robot:
    KRG-DEU
    FS003NFD70
    S/N 0496
    Date: 2008/2/14
    AS Software: AS-R1D0021F
    Servo Software: SV-R5000007


    The robot was good working this spring with no problem.
    The robot’s neibor is another one – good working. It’s just the same, has s/n 495 and AS, servo software – absolutely the same.



    If is it possible to reinstall AS and servo software? How to do that? Or maybe there is another simplier solution.


    Thank you a lot for your answer !!


    With respect,
    Kulakov Boris

  • Place your Ad here!
  • Welcome to the Forum........ :beerchug:


    Hmmmm.....not too sure about the CPU error when error log saving.


    Full file data save is: SAVE alldata


    Please check integrity of 1KP board connections for Ext Estop, Safety Fence/Ext Trigger and Ext Hold on X7/X8/X9
    Usual occurrence for prevention of Motor Power is:
    Permanent Error
    Safety Circuit Channel O/C - E stop, limit switch in robot arm, safety fence circuit open, ext trigger open.

  • Good day ! :icon_smile: Thank you for your warm welcome, fast and reasonable answer!



    Have been done (with no result):
    – The robot’s electrical scheme (X7,X8,X9 – 1KP board, come up to disconnection the DIO cables) has been converted to original factory settings according to provided table states (of factory setting for terminal block connectors).
    – Four Fused have been checked (F1,F2 at 1NQ board and F1,F2 at 1KP board),
    – the voltage supply at the 1KA board (TP2-TP4, TP6-TP9: -12V, +12V, +5V, +3.3V, +1.2V, +1.3V, +2.5V ) – and 24V at 1KP board have been checked.
    – Leds state at 1KP board is normal.


    – The teach pendant shows NO errors when pushing Motor power ON button. The b2.el - attached error log file-contains repeated mistake message (D1507)AC primary power off – which is occurred while shutting power supply down. That’s normal as I understand and occures at nearby normally working robot too.


    What do you think all about it?
    If it is any chances for reinstalling correct AS/servo software (for example – from nearby twin normally working robot)?
    How to understand that hardware is normall?


    THANK YOU A LOT !


    With respect,
    Kulakov Boris

  • You're welcome and also you provide many details which also helps greatly to try and diagnose issue.


    Ok, so I checked your attached error log:
    1. Yes, you are correct, each time you power off controller - AC Primary Power Off is logged and is normal.
    2. According to error log, motor power is turning on as there are many statements.
    - This means it is seeing Motor power on signal.
    - This should light up Motor Power LED (Orange) on front of Controller + Motor symbol (Orange) in top right corner of screen.
    - If neither of these appear, does red EMG symbol show in top right corner of screen (can you attach image).


    If you are seeing both of the above, then Motor Power is on (but in Teach Mode you will not hear anything until you place Run/Hold switch on front of controller into Run and press deadmans.
    - You should then hear brake release on motors (when brakes release - motor power is applied to servo's and you should be able to move robot manually).
    - If Run/Hold switch working, you should see in top right corner of teach pendant status toggles between Run(Yellow) or Hold(grey).
    - If Teach Pendant displaying permanent hold - then Run/Hold switch is faulty (stuck in hold).
    - Also confirm pins 5-6 and 7-8 on X8 are linked and also confirm pins 7-8 are linked on X9.


    It is possible (software) that you have to have deadmans pressed first before pressing motor power on - so please try this also.
    - Strange if this is the case as EU Spec Controller do not usually have this feature, North American Spec do.
    - If this happens, let me know?


    As for software change, would be first time I hear of software problem causing this problem, so let's explore hardware first........


    Can you make full file save (not error log) and attach so I can look at?

  • Good day! Thank you for the letter!!


    Articulately:
    1. What do you mean «According to error log, motor power is turning on as there are many statements»? I’m not sure that understand that correctly.
    2. There is no any lamp lighting – nor the controller’s Motor power lamp , nor Motor orange simbol at the top-right part of the screen (the screen photo is attached).
    3. While Run/Hold is switching, the appropriate lamp’s image has appropriate colour – Yellow/Grey, for the EMG button – the same.
    4. Confirm: 5-6, 7-8 pins at X8 and 7-8 pins at X9 are connected
    5. The deadmans pressed have no effect on Motor power ON button.
    6. The Motor power ON button was checked separately – by AUX 0601 Dedicated input signals/Ext. MOTOR ON – at Dedicated 1007 signal number the robot has accepted 24V. No any effect..
    7. Full backup file saved (with some programs deleted) is attached.
    8. What about the software problems… I don’t know, but the CPU error while save file.el repeated at the robot. But the nearby working robot «eats» that command and saves the file.


    What’s your advice – how to restore the robot?
    Is it possible to reload/reinstall some files, listed at the beginning of the backup file? The Backup file’s top contains:


    .*=== AS GROUP === : AS_R1D0021F 2007/12/03 14:29
    .*USER IF AS : UASR1D0021F 2007/12/03 14:14
    .*USER IF TP : UTPR1D0021F 2007/12/03 14:24
    .*ARM CONTROL AS : AASR1D0021F 2007/12/03 14:27
    .*USER IF AS MESSAGE FILE : MAS1D021FEN 2007/12/03 14:27
    .*USER IF TP MESSAGE FILE : MTP1D021FEN 2007/12/03 14:29
    .*ARM DATA FILE : ARMR1D0021F 2007/12/03 14:27
    .*USER IF IPL : UIP02080000 2007/06/28
    .*ARM CONTROL IPL : AIP02080000 2007/06/28
    .*=== SERVO GROUP === : SV_R5000007 2007/12/12 17:31
    .*ARM CONTROL SERVO : ASVR5000007 2007/12/12 17:04
    .*SRV DATA FILE : ASPR5000007 2007/12/12 17:29
    .*ARM CONTROL SERVO CONT. : ASCR5000007 2007/12/12
    .*ARM CONTROL SERVO FPGA : ASFR5000002 2007/08/21 08:20


    (as I understand, the files like ASVR5000007 – are software drivers)
    Moreover, troubleshooting manual recommends in many cases: «reinstall AS/servo software».


    Thank you !


    With respect,
    Kulakov Boris

  • Good another day!


    Adds:
    – while «save r2» command – the same CPU error D0001 occurs (The KCwin's screenshot is attached)… The controller hangs up and red led LD1 lights at 1KA/1RA board (the photo is attached)
    – Is it possible to change some boards between the robots for understanding what’s the problem source? Without reprogramming – it is desirable. Can such change be harmful for the tested robot and the original parts of another one?


    Thank you!


    With respect,
    Kulakov Boris

  • Hmmm.....Ok, so reading all information we have 2 problem:
    1. No Motor Power On.
    2. CPU Error during save.


    Error log statements included 'Motor Power On' messages - which means Motor Power On request read by 1RA board correctly.
    (this normally confirms AS/SV is ok - and failure is down to internal board).


    To rule out Motor Power switch/harness connection to 1NS board (Front Controller push button board).
    - Connect toggle switch between pins 5 and 6 on X9 of 1KP (external motor power on) and toggle - if motor power orange appears on Teach Pendant - then faulty 1NS Board/Switch/Harness.


    It is possible this is software, but I have never seen this combination of problem before (so I still would like to prove hardware first).


    Reference your image of 1RA (I attach small revision to it - Yes 1RA is indicating problem.
    1. It could be shadow, but it appears from image to me not all dipswitch are in full OFF position - Can you cycle all switches here and make sure all are OFF except No.1.
    - Then try save again to see if CPU error removed.
    - What is red wire for/connected to......I never seen this before?


    2. If no change, I suspect data corruption, carry out Dipswitch 8 initialization again.
    - Do not load any data, but try and make file save again.
    - If CPU occur again - then 1RA has problem and need replacing.
    - You could swap 1RA from other controller (temporary) and repeat file save again and see if clear (you do this at own risk....ESD precaution and make file save from other Controller BEFORE SWAP).
    - Also note battery is with 1RA, so when you transfer board, then no loss of data as long as battery stay attached.

    - If is clear of CPU error then confirm faulty original 1RA (not software).


    3. If the borrowed CPU is clear of file save error then:
    - You will have many errors relating to zeroing/check sum and others.
    - Reset all errors - and you will need to reset CHECK SUM ERROR.
    - If you can clear all errors try Motor Power On again.....if lights then original 1RA board is the common fault, if still not light, then you have another problem.
    - So leave 1RA in and swap 1KP (confirm links, switches are same) and try Motor Power again.....if light, then 1KP need change also, if still not light then 1KP probably ok.
    - Problem would then be on 1NQ board (main board with contactors) - this you can exchange between controller no problem.


    When placing 1RA back in original controller you will probably receive Jt abnormal errors....which should clear....as long as you have not made changes when it was in other suspect Controller, should be OK.
    - But if you have, you will need to hardware initialize and reload original backup to restore correctly.


    You always carry risk when swapping known good boards between good and bad controllers, so use caution and at your own risk
    Also note, 2 version D Series Controller - D Controller has 1KA/1KB 'red tabs on board levers' and D+ Controller has 1RA/1RB 'yellow tabs on board levers' - Cannot mix coloured tab boards - According to your AS revision, you use D+ Controller


    You cannot extract AS/SV from other 1RA board, it is non readable.
    - However AS/SV is replaceable and contained on 1KJ or 1QJ sub card on 1RA board (half size of credit card).
    - You could swap this card between 1RA for testing, but could result in data corruption on good card......I would advise against this unless you have AS/SV and backups available.


    I hope this helps................

  • Good day!
    Thank you for the instructions!


    No result :wallbash:, one intention.
    To your answer:


    (this normally confirms AS/SV is ok - and failure is down to internal board).
    «AS/SV» – do you mean AS/servo software?


    – Connect toggle switch between pins 5 and 6 on X9 of 1KP (external motor power on) and toggle – Done, no result (I haven’t done any software setup before toggling).


    It is possible this is software, but I have never seen this combination of problem before (so I still would like to prove hardware first). If it is software – what should we do then?


    Reference your image of 1KA (I attach small revision to it - Yes 1KA is indicating problem.
    1. … it appears … to me not all dipswitch are in full OFF position?
    – the DIP switch have been cycled and checked: all switchs exept 1 are in OFF position
    – Then try save again to see if CPU error removed.
    It didn’t
    – What is red wire for/connected to......I never seen this before?
    The red wire you mentioned is a RAM battery holder’s one.
    2. If no change, I suspect data corruption, carry out Dipswitch 8 initialization again.
    – Do not load any data, but try and make file save again.
    Done, no result (as I understand, you mean "1. Initialization of the system" by DIP switch 8 initialization)
    – If CPU occur again - then 1KA has problem and need replacing. Can it be the software problems, isn’t it? Or categorical NO? This is important.
    Do you know what whould cost approximately a new one 1KA board?
    – You could swap 1KA from other controller (temporary). I haven’t done this. I am not allowed yet the 1KA boards swapping. Both boards can be damaged and another one robot will chill out in a case of electrical damage outside the 1KA board that caused its fault.


    The intention:
    Is it possible to remove RAM battery from the 1KA board at the 1 hour period, then inset it back and then try reinitialize the controller?
    What whould be the procedure? It should be the same as I have done previously? Is it better to perform a factory initialization? (How to get special fille with factory settings and procedure for that?)
    Excuse me if it is too many questions.



    THANK YOU again for time spending and really wish to help me!


    With respect,
    Kulakov Boris

  • Hmmmmm...................yes......many questions indeed............. :top:


    OK, locate push button on 1KP Board (this is Limit Switch Override) - Hold this button in whilst turning on Motor Power.......Does Motor Power come on?
    - If so, does motor power then go off when you release push button on 1KP?
    - If this occurs then problem is a limit switch that is connected on Arm.....if none exist, then must be broken connection between robot/controller or jumper missing from robot arm(rear) or jumpers not properly connected on motherboard (card rack where 1RA/1RB/1KP board) are connected.
    - If Motor Power is achievable here, this would not be connected/fix the CPU error......so that would still require attention........but I still believe this is 1RA problem.


    AS/SV, yes I mean AS and Servo Software....
    Toggle switch does not require any software changes to function......switch toggle should result in Motor Power On (as long as Estop circuit and no error is displayed in either Teach/Repeat Modes).


    I still don't understand 'red wire'......from battery there should be 2x black and 2x red wire to brown/orange connector (I can see these).....but that red wire I still don't understand...... ???


    AS and SV are stored on 1KJ/1QJ Board (small credit card sized board in middle of 1RA) in flash (non volatile) memory.
    - So if battery left disconnected/exhausted......would not affect AS/SV......only RAM which is volatile (user data - programs, locations etc).
    - So what you did with dipswitch 8 (initialize) and reload is correct procedure.
    - When you do dipswitch 8 procedure and do not load backup, Controller is in a condition where Robot Model is not set, therefore no SV is loaded from 1RA to 1RB board.....and 'failed to load servo errors' produced.
    - SV cannot not load until it knows what SV is required, the required SV is determined by Robot Model set in software and also must match hardware settings on 1RB and 1GM (small board on 1RB).
    - When you load previous backup, then Robot Model exists in backup, so during boot up, correct SV from flash can be loaded to match Robot Model.
    - According to your previous posts, this is good and you have no errors, as you have used a previous backup from that same robot.
    - This is why I do not suspect software as being the problem...........but like I said, I have never seen this combination of CPU error and Motor Power before.
    - That is why I suspect it now could be 1RA problem.
    - I would be considering swapping 1KJ/1QJ between Controllers, as this would rule in/out software problem on 1RA.


    You can swap 1KP boards without loss/corruption of data safely.....this would at least prove 1KP board.


    I think new 1RA would be expensive, maybe >3000 Euro.


    ALL Controllers from factory are supplied with Setting/Data sheets for service engineers to return to 'as supplied condition'.
    - If these are missing, you would need to contact Kawasaki Germany (KRG) and they should be able to provide original settings and software if required.
    - But as these are older models, they may charge........

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners