R-30iB Mate TP stuck in auto

  • We're doing a small 5 robot cell integration for a customer and at the first startup the Teach Pendants are showing in auto even though the cabinets are in T1. Even after loading the software it's still showing us in auto. Has anyone seen this before? What's the fix?


    Alarms are,
    PRIO-378 PMIO Chnl 1 Slot 1 Conn Err
    SRVO-419 PROFIsafe comm. error 1,1
    SYST-301 External mode select is not


    I know we can bypass the profisafe error but we can't until we're not in auto. The PRIO I'm assuming is because we haven't configured any IO yet? The syst-301 I'm not sure, I've googled and looked at 3 manuals(including the ones provided) and CANNOT find this error anywhere. The only place it seems to show up is with some CNC machine?


    We have tried everything we can think of of the top of our heads and have come up short, talked to several Fanuc friends and they all have never seen this issue. We even contacted Fanuc support and were told to check the E-Stop wiring. It all looks to follow the prints. Hoping it's something simple we're missing, any help is greatly appreciated.
    Thanks in advance.

  • Place your Ad here!

  • Does it say auto when the TP is also in the on position? Does the cell automation work properly otherwise?


    Sent from my SM-G930P using Tapatalk


    Yes, when the teach pendant is turned on we just add the deadman (servo-003) error and the TP enabled in AUTO mode (syst-045) errors, even though the cabinets are in T1. We've even turned the cabinets to auto to see if they were wired backwards and no difference.
    This isn't a "cell" yet, Only robots with power. Nothing else has been done yet, no safety,plc, etc.

  • Only thing I can think of is to go to System, config, and make sure you're in local and not remote until you get your PLC hooked up. Also check your IO mapping and make sure it's active. I would also check interconnects and background logic if you have it just to make sure nothing is forcing a bit on.


    Sent from my SM-G930P using Tapatalk


  • Only thing I can think of is to go to System, config, and make sure you're in local and not remote until you get your PLC hooked up. Also check your IO mapping and make sure it's active. I would also check interconnects and background logic if you have it just to make sure nothing is forcing a bit on.


    Sent from my SM-G930P using Tapatalk


    We have checked all this, I'm leaning towards a wiring issue, it just doesn't seem that all 5 would be worked wrong from factory?

  • Sounds like the wrong option got loaded at the factory. Did you order an external mode select box from Fanuc for these robots?


    Here is the fault explanation from linuxsand's website:


    Quote from http://www.linuxsand.info/fanuc/code/SYST-301


    SYST-301 External mode select is not available


    Cause: External mode select function (J569) is loaded, but External mode select is not available in this op panel.


    Remedy: "Delete 'External mode select function or use op panel that has no mode switch.

    Check out the Fanuc position converter I wrote here! Now open source!

    Check out my example Fanuc Ethernet/IP Explicit Messaging program here!

  • Did anyone find a solution to what Bagel-Dog was having with his robot. I have same issue here, auto/T1 switch is not doing anything, robot thinks it is in auto.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners