Program can't run in AUT mode [Even with safety circuit is ok]

  • Hi everybody!

    Well, I have KUKA KR sixx R700 Agilus, using KUKA C4 Compact. I'm trying to put it in AUT Mode again. The robot worked well in this mode but, recently, I've configured some I/Os in WorkVisual to active a gripper. So, when I downloaded the program from WorkVisual to C4 Compact, some configurations, apparently, have undone. So, when I select the program and press start, in AUT mode, nothing happens. "All Commands inhibited".

    It's strange, because, this message, generally, occurs if is something wrong with the safety circuit, but it is working very well (I'm using x11 interface). I can trigger everything to run the program but the robot continues blocked. Why? I really do not know what happened, what can be unconfigured when I send the project from WorkVisual to C4. The project looks Ok, so, what errors can cause this, besides problems with safety circuit?

    I took some prints to explain and expose better the problem.

  • I changed $MOVE_ENABLE, $DRIVES_ON and $I_O_ACT from 1026 to 1025. $DRIVES_OFF and $CONF_MESS I changed to 1026. When I did it, I thought the robot would activate. But, nothing happens. When I saw the Outputs, $STOP_MESS and $ALARM_STOP is activated. So, something is wrong.

    So, what is disturbing the robot activation? I really do not know...

    I am trying to run the program in AUT mode, but, in the future, will run in AUT EXT mode.


  • working with robots requires certain skillset. this is why there are manuals, training etc.

    to run robot program following has to happen:
    1. select program
    2. power up drives
    3. ack. messages (this does not work on status messages, and you have four of them)
    4. issue start command

    this always applies, regardless of operating mode. you are failing to power up drives because you have problems and robot is displaying messages that need to be taken care off.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • I don't think this messages are the cause of the problem. The robot already run in AUT mode with this messages.
    This problem (robot isn't running in AUT mode) has come up when I was mapping I/Os to the gripper of my robot in WorkVisual. When I sent the project from WorkVisual to C4 compact, probably some configuration has lost. But I really do not know what can be.
    Anyway, I'll attach a print with the ack messages. But I think, that messages are about another problems that I'll resolve, not about AUT mode. [x44 has not been used and EIP is not configured totally yet.].

    I really puzzled about it because AUT mode, before IO mapping, run normally and comparing both projects, I really don't find the differences. I really confused about it.

  • you can activate previous project and be back in business.
    WoV also has compare function though i don't think it shows details for things like I/O mapping.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • The problem has solved. Some error occurred when I tried to activate the project in WoV in the last time. So, i re-sent the project and the robot works fine again.

    Thanks for your help!

Advertising from our partners