Increase roboguide performance?

  • Hello. Recently I started using roboguide for robot simulation. I have a lot of experience using ABBs robotstudio, which has generally been pretty good. I can't help but notice that the performance in roboguide is quite dreadful, however. I've tried everything in the help guide, such as checking all the performance boxes, making the cad import less detailed, using my dedicated graphics card instead of my integrated card, etc. Nothing works, and the program always becomes very laggy and slow after importing just a few cad fixtures. I know there probably isn't a way around this, but I thought I would ask here to see if you guys had any ideas on how to speed this program up. It's a shame that graphic wise, it looks very sub par compared to robot studio, and it runs at a quarter of the framerate. My specs are as follows:


    i5 2.4ghz
    24gb RAM
    770m gtx video card


    Please let me know if you have any ideas. Thanks!

  • AD
  • What rev are you using?


    I just upgraded from rev G to rev M because G didn't support the p-350. It runs noticeably slower than rev g.


    I had a cell with huge, detailed cad files, plus two extended axes (140' linear runway and 15' high x 15' long rotating cantilever that the robot is mounted to), that ran before just fine (30+ fps), now I can barely rotate the camera.


    Has anyone else experienced this when upgrading revs?


    I'm hoping they fix it with the next release.


    Your specs look more than adequate, roboguide loves ram, and you have plenty of that.

    Edited once, last by pdl ().

  • Try to go to NVidia Control Panel, then 3D-settings and the Program settings tab and set Roboguide (Weldpro or whatever) to use the NVidia GPU. I had to do this on my Quadro, because Roboguide was using the standard, integrated Intel GPU, which caused it to be laggy as hell...


    You might also want to check the settings - in Roboguide, go to Tools -> Options and check the Teach-Time Refresh Rate slider position.

    Edited once, last by bidzej ().


  • Try to go to NVidia Control Panel, then 3D-settings and the Program settings tab and set Roboguide (Weldpro or whatever) to use the NVidia GPU. I had to do this on my Quadro, because Roboguide was using the standard, integrated Intel GPU, which caused it to be laggy as hell...


    You might also want to check the settings - in Roboguide, go to Tools -> Options and check the Teach-Time Refresh Rate slider position.


    Wow, it was driving me crazy. Thanks a lot. At first I couldn't see the slider which by defaut is set to 1. :bravo:

  • I also had to change the "Thread optimization" setting to off in the NVidia Control Panel.

    Huge difference in frames per second when I turned that off. You need to close Roboguide and restart it to have gpu changes take effect.


    NVidia Control Panel -> Manage 3D settings -> Program Settings for Roboguide -> Threaded optimization OFF

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now