Filezilla to connect to R30i B

  • I tried to connect to R30i B with Filezilla 3.7.3 on windows 7 64bit.
    I saw that it connected to the Fanuc, but then got a some red lines that said that the folder structure could not be read.
    So I could not see anything in the robot.
    What could be wrong?
    I connected with IP adres and default port 21. I connected anonymous once, and also once with the login an password : same result.
    If it should work, in what folder should I be : MD?

  • Place your Ad here!
  • Hi,


    I found this case on the internet that is exactly the same as mine :
    Hello all,


    I need help. I am trying to connect a PC to a r30ib fanuc robot controller. I am at the point where I can ping the controller and ping the pc from the controller. I am also seeing the controller in my web browser. But when I try to connect using filezilla I get the following:
    Status: Connecting to 10.10.150.125:21...
    Status: Connection established, waiting for welcome message...
    Response: 220 R-30iB FTP server ready. [HandlingTool V8.20P/06]
    Command: USER anonymous
    Response: 230 User logged in [NORM].
    Command: SYST
    Response: 215 UNKNOWN [HandlingTool V8.20P/06].
    Command: FEAT
    Response: 500 Command not understood.
    Status: Server does not support non-ASCII characters.
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "md:\" is current directory.
    Error: Failed to parse returned path.
    Error: Failed to retrieve directory listing

    Someone answered :
    Your server uses a very uncommon and ancient, DOS-like path syntax. Try setting the server type to DOS in the site manager.


    Now I am not more at the robot, so I cannot try this anymore. Has anyone experience with this?

  • In Filezilla's Site Manager setup the following:
    Host: [your robot IP] Port: 21
    Protocol: FTP - File Transfer Protool
    Encryption: Only use plain FTP (insecure)
    Logon Type: [Ask for password]
    User: (if password option is enabled, use login from Password setup, otherwise use login from setup->host comm->FTP screen)
    Password:


    Go to Tab "Advanced", setup following:
    Server Type: DOS with backslash separators
    Bypass proxy: Unchecked
    Default local directory: leave empty
    use synchronized browsing: Unchecked
    Directory comparison: Unchecked


    Go to Tab "Transfer Settings, setup following:
    Transfer mode: Default
    Limit number of simultaneous connections: Checked
    Maximum number of connections: 1


    Go to Tab Charset, setup following:
    The server uses following charset encoding for filenames: Force UTF-8


    Now it should work

  • Hello everyone,


    Settings provided by Daniel is correct, it should work.
    If it still does not work then try changing these two
    server type : 'DOS with forward-slash separators, Transfer mode as 'Passive' and rest of the settings same as what Daniel has said.

  • If you're connecting just the one time and don't want to save the path, type in the IP address along with a backslash at the end.


    192.168.0.1/

  • In Filezilla's Site Manager, I have it working with danielsk 's settings above. However it only shows me the md directory. How do I also see the fr, mc, md, mdb, rd, ud1, and ut1 directories?


    I can see all these if I type 192.168.1.174/fr: into the Quickconnect host, and then click the double-dot directory to go up a level in the remote site. However I would like to get Site Manager configured to show that whole list by default, rather than locking me into just the md directory.

  • Ah-hah! So I copied @danielsk's settings above, but have changed the server type to be able to add a default remote directory.


    Change

    Server Type: DOS with backslash separators

    And add

    Default remote directory: \fr:


    But actually after discovering the above works, I found this is even better for me. So on each connection I can choose FR, MD, whatever I want.

    Default remote directory: \

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners