Axis 3 is turbiny oposite

  • Question to experts.
    Krc1, soft 2.3.24
    Should stand on exhibition. Owner want it running. Problem is that in manualna jog a3 turn in oposite way that should. And in cartesian frame doesn't follow axis.
    While running program it react corectly.


    What could couse such bahavior?

    There are no impossibles, there are only possibles waiting to be found.

  • AD
  • I don't see how hardware could cause different behavior depending on used motion (program execution and jogging).
    As mentioned already, check machine data. Note this is not just one variable, it is a complete set of all parameters that distinguish your robot from some other model. (It is literally hundreds of settings). Bunch of them are used for jogging only.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • What is the history of this robot? Was there a time when it jogged A3 properly? You say it moves correctly when running a program -- did you create this program, or was this a pre-existing program that was already in the robot? Who might have tampered with $MACHINE.DAT, and when?


    The key issue is, robots are repeatable, even if configured incorrectly. So it is possible to program a robot that is badly mastered, or has an incorrectly configured axis, and the robot will still run that program correctly (assuming all hand-taught points, no mathematical shifts, etc). But whenever someone fixes the robot properly, that program will no longer function.


    You could try programming a set of LIN_REL motions in Base, run the program, and see if the motions are carried out correctly.


    Still, most likely this is a problem in $MACHINE.DAT, as Panic has stated.

  • i would first try to identify if and what is different by comparing current MADA (KRC:\R1\MADA) with factory defaults which is usually located on D: (D:\KUKA_REL\INTERNAT\MADA or similar)



    to replace it, of course always make backup of anything you plan on changing....


    then, login as Expert, deselect any program (robot and submit), navigate then copy factory MADA for the robot and overwrite working copy in KRC:\R1\MADA

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Thanks Panic.
    After 3 hours of restarting system, loading and changing machine data, I found correct ones.
    :bravo: :bravo: :bravo: :bravo: :bravo:
    Some ba :censored: ard took out nameplate. So it was game guess who am I.
    But it worked.
    :dance: :dance: :dance2: :dance2: :dance: :dance: :dance2: :dance2:
    Once again thanks folks. :merci:

    There are no impossibles, there are only possibles waiting to be found.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now