Cannot run Kuka in T2 and AUT mode

  • Hello, I can't run KUKA KR C4 in T2 and AUT mode. When I turned the Smartpad to T2 or AUT mode, the drive could not be enabled. When I pushed the Start button, there was a message said that "Active commands inhibited". Could anyone help me with this problem?



    These are some settings in machine.dat :


    SIGNAL $DRIVES_ON $IN[140] ;ANTRIEBE EIN
    SIGNAL $DRIVES_OFF $IN[1025] ;ANTRIEBE ENABLE


    SIGNAL $SAFEGATE_OP $IN[1025] ;SAFETY GATE ON PATH STOP
    SIGNAL $MOVE_ENA_ACK FALSE



    SIGNAL $IMM_STOP $IN[1025] ;NOT-AUS VON DER SPS
    SIGNAL $AUX_POWER $IN[1026] ;EXTERNE SPANNUNGSVERSORGUNG AKTIV
    SIGNAL $T2_ENABLE $IN[1025] ;SAFETY-SPEED
    REAL $FAN_FOLLOW_UP_TIME=5.00000 ;NACHLAUFZEIT FUER DIE FAN-ANSTEUERUNG
    SIGNAL $ROB_STOPPED $OUT[1023] ;ROBOTER STEHT
    SIGNAL $ROB_CAL $OUT[1001] ;ROBOTER SYNCHRON
    SIGNAL $PRO_ACT $OUT[1021] ;PROZESS AKTIV
    SIGNAL $PRO_MOVE $OUT[1022] ;PROGRAMMBEWEGUNG AKTIV

  • Place your Ad here!
  • Before you can run robot, drives must be on. To execute program, you must select one. I am pretty sure that variables mentioning fan are not related to this. What is value of move enable?

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • OK, what is your safety interface? How is it setup? Did you talk to your integrator? Are you even allowed to use T2? Are you sure?

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • When the start up mode is on in T1 mode, I can not change from T1 to T2 mode. When the start up mode is off in T1 mode, I can change to T2 mode. But the robot can not move, there is a message " "Active commands inhibited" when I try to enable the drive.

  • Wait, you're trying to use StartUp Mode? StartUp Mode only works for T1. It explicitly disallows any other mode. StartUp Mode is only to allow you to slow-jog the robot when the safeties are not engaged. In order to operate in ANY mode other than T1, you MUST have your safeties configured and operating.


  • I am a newbie on Kuka robot. Could you tell me how to configure the safety? :merci:


    You should go through the System Integrator Manual which should have come up with your robot in Parts and Docs DVD. Look for chapter named Safety and it has been explained in detailed. Also there should be a booklet name Startup with the robot inside the controller which gives steps to follow during first startup of the controller and guide you to do the safety configuration of the robot.


    Also, you need to understand how the safety circuit of the robot is electrically connected. External E-Stop and Door Lock connections are quite important if you have it in the circuit.


    Thanks

  • robot must have safety interface and it must be happy in order to enable drives.
    on KRC4 that interface is either hardwired to X11 or it is created through network with SafetyPLC.
    check download section for X11 examples (make sure to pay attention and look at the one matching your controller)

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • One question can you just tell me what are the error messages you saw after changing the operating mode from T1 to T2.
    Need to know all messages..

  • Are you working with an Integrator? If so, they should be able to help. If not, you'll have to use the KUKA doc to wire X11. Start with a simple circuit (say an operator door switch) to test your understanding. Then add more signals like light curtains, laser scanners, etc.

    Building robotic welding systems.


  • Are you working with an Integrator? If so, they should be able to help. If not, you'll have to use the KUKA doc to wire X11. Start with a simple circuit (say an operator door switch) to test your understanding. Then add more signals like light curtains, laser scanners, etc.


    Thank you for reply me. When I change to T2 mode, there is an error "Cartesian velocity is still limited in T2". Then, when I select a program and try to push the run button, there is a message "Active commands inhibited". The Integrator is not here now. I find the X11 plug but we don't have any circuit. I am trying to seek help from the Integrator . If you have some solutions for me, please help me :icon_mrgreen:.

  • Thank you for reply me. When I change to T2 mode, there is an error "Cartesian velocity is still limited in T2". Then, when I select a program and try to push the run button, there is a message "Active commands inhibited". The Integrator is not here now. I find the X11 plug but we don't have any circuit. I am trying to seek help from the Integrator . If you have some solutions for me, please help me :icon_mrgreen:.


    Hi,


    "Cartesian velocity is still limited in T2".


    This is not an error message. It is saying the velocity is limited in T2 mode for user safety. You just need to press acknowledge button and then the robot will execute the start command without any problem. And if you want to bypass the safety circuit in order to move the robot in T1 or T2 mode, you have to select Start-up mode operation by following MENU commands Start-Up>Service>Start-Up mode.


    Thanks




  • Thank you. If the start-up mode is selected, I can not change to T2. Only if the start-up mode is not selected, I can change to T2 mode. But in T2 mode, the button for start-up mode is grey and can not be selected. I don't know why.

  • Thank you for reply me. When I change to T2 mode, there is an error "Cartesian velocity is still limited in T2". Then, when I select a program and try to push the run button, there is a message "Active commands inhibited". The Integrator is not here now. I find the X11 plug but we don't have any circuit. I am trying to seek help from the Integrator . If you have some solutions for me, please help me :icon_mrgreen:.


    Per KUKA, on KRC4, Jogging in T2 is not allowed. You can only run programs in T2.


    There is a safety issue of running at high speeds, and then switching modes and the robot moves faster than expected when the pendant is in your hand.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners